Photoshop: Eyedropper tool changes background swatch, not foreground swatch

  • 4
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Photoshop: Color Picker sets background swatch instead of foreground swatch

When using the swatches or eyedropper tool my color selection goes in the background swatch and not the foreground swatch. How do I return it back to default?
Photo of DEAN JANSA

DEAN JANSA

  • 2 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 4
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15328 Posts
  • 2222 Reply Likes
Are you on mac or windows? That sounds like either the alt key (win) or option key (mac) is stuck.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Official Response
Go to the color palette/panel and look at the two swatches in the top left.
You have the background swatch selected there, so the eyedropper is picking the background color.
Select the foreground swatch instead.
Photo of DEAN JANSA

DEAN JANSA

  • 2 Posts
  • 0 Reply Likes
Thanks, this has corrected the problem....sometimes it's so easy....
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15328 Posts
  • 2222 Reply Likes
Great. Thanks for the update. Glad Chris's solution worked for you.
Photo of Juan C Walls

Juan C Walls

  • 11 Posts
  • 2 Reply Likes
When using another tool instead of the Eyedropper that allows picking colours (like Brush tool), You ALT-Click to change foreground colour. Is there a way to change background colour? (without going to the color palette and selecting the background swatch, of course)

What I use to do is exchange the colours, (by pressing x), pick the colour I want for the background and then exchange colours again.
Photo of Francesco Cioce

Francesco Cioce

  • 5 Posts
  • 0 Reply Likes
Ok, here's my issue:

if I click and hold "Option" to activate Eyedropper Sample Color and choose a Foreground color from the image, I always got the Background color instead.

I went through the Keyboard Shortcut Menu, I discovered there was a "Default (modified)" set I never created. So I trashed it, and selected the "Default" set.
Sample Color tool worked for a while, and then got back to the previous issue (set is still "Default").
I can't choose Foreground color with the "Option" shortcut (and I can't change it in the Shortcut Menu either, because it does not recognize "Alt/Option" as a key).

Any help would be appreciate,
Franz

iMac Intel 24" (original European keyboard)
Osx Lion 10.7.5
Wacom Bamboo tablet

This reply was created from a merged topic originally titled
Photoshop CS6: Shortcuts issues!.
Photo of Michael Stancato

Michael Stancato

  • 4 Posts
  • 0 Reply Likes
This has not worked for me. My left option keys is dead on my extended keyboard though. I'll try to find someone with a keyboard to test it. But that seems odd since the right option key works fine. Any other suggestions?

MacPro 10.8.4
Photoshop CS3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 838 Reply Likes
Did you check the color palette? A stuck key is one of the less frequent causes...

This conversation is no longer open for comments or replies.