Photoshop CC 2014: Extract Assets dialog is always empty (proxy problem)

  • 2
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
Hello,

I downloaded the "Extract PSD assets workflow" sample files offered by the Photoshop CC 2014 "Welcome" screen (running on Windows 8 x64). When I open the any of the PSDs, select any combination of layers, and launch the Extract Assets dialog, it always appears empty. The dialog always states "There are no layers being extracted" regardless of the various selection combinations I've tried launching the dialog with.



Furthermore, the Cancel button does nothing when I click on it. The Done button pops up a confirmation modal, but when I press OK on that, it only closes the modal popup.

The Extract Assets dialog just sits there and does nothing. Please help me get it working!

Thanks in advance!
Photo of Mike Wach

Mike Wach

  • 3 Posts
  • 0 Reply Likes
  • sad

Posted 4 years ago

  • 2
Photo of Mike Wach

Mike Wach

  • 3 Posts
  • 0 Reply Likes
I have resolved the problem myself. It was caused by running Charles HTTP Proxy. I noticed because when I open the Extract Assets dialog, a flood of requests for this URL begin: https://localhost:64253

The solution was to specify exactly which ports I would like SSL proxying enabled on, rather than proxying all ports on my system.

P.S. Why does the Extract Assets dialog need to access the URL https://localhost:64253 ???
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Because it is using HTTPS to communicate with a service on the local machine.
Photo of Mike Wach

Mike Wach

  • 3 Posts
  • 0 Reply Likes
Ohhh okay, so I'm guessing it's a local service because other Creative Suite apps may use the feature, such as Dreamweaver...right? haha. Oh well...
Photo of Anurag Kapur

Anurag Kapur

  • 1 Post
  • 0 Reply Likes
Where did you specify which ports to enable SSL proxy on?