Lightroom: Export with all Metadata doesn't include lens data

  • 1
  • Problem
  • Updated 4 years ago
  • (Edited)
Lightroom recognize my lens (most Canon serie L) but when I export image with option "All Metadata" the lens data isn't exported.
Photo of Jean-Sebastien Ouellet

Jean-Sebastien Ouellet

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
What do you mean?

The camera raw settings for lens corrections (e.g. profile-based) are most certainly exported with the rest, in my copy of Lr5.6, on Windows anyway.

Do you mean that the lens profiles themselves don't come too? If so, then I agree, but then neither do the camera profiles..

Perhaps some clarification is in order..

R
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
It just occurred to me that you might be talking about exif metadata. If so, perhaps you could post a link to a sample file so we can test behavior - I just checked a random CR2 raw file and lens exif metadata seemed fine.

PS - make sure you are running the latest version of Lightroom.
Photo of Jean-Sebastien Ouellet

Jean-Sebastien Ouellet

  • 3 Posts
  • 0 Reply Likes
All exif data is ok within lightroom (yes, latest 5.6). But it's when I do a Export, with option metadata > Include : All Metadata, the properties of exported file contains most exif data, including all camera data but no lens data.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
Can't reproduce - e.g. exported files can be re-imported in Lightroom and include lens metadata.

Does problem always occur, or only with some files?

How are you assessing presence/absence of lens metadata in exported file?
Photo of Jean-Sebastien Ouellet

Jean-Sebastien Ouellet

  • 3 Posts
  • 0 Reply Likes
I was looking at the file properties directly from windows, I noticed this problem a while ago when importing to 500px.

The camera data is ok, but the lens section has empty data

ex.
Camera maker : Canon
Camera Model : Canon EOS 5D Mark III
etc...
Lens maker :
Lens model :

I think it's a EXIF compatibility problem... I noticed the info is missing from the original raw file also...
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 382 Reply Likes
|> "I noticed the info is missing from the original raw file"

I think you're on to something.

Metadata handling is kinda messy, but it sounds like you can fix by:
1. straightening out your raw files (and maybe write something to xmp too).
2. read metadata (Lr will incorporate metadata from *both* raw file and xmp).

Then it should be in exported file too (fingers crossed, knock on wood..).

What do you think?

PS - MetaRep is a (free) plugin (that I wrote) which may help.

~R.