Lightroom: Export to DNG does not include ALL the photo's develop metadata

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
If you do not use DNG as your default format in Lightroom, but attempt to export a photo to a dng file, it will not include ALL of the develop metatdata. For example, it will include brightness and luminosity settings, but not the spot-heal tool adjustments. This seems like a pretty nasty bug if you use export to dng as a backup solution.
Photo of M Lavin

M Lavin

  • 7 Posts
  • 1 Reply Like
  • frustrated

Posted 7 years ago

  • 1
Photo of Lee Jay

Lee Jay

  • 990 Posts
  • 135 Reply Likes
Are you sure? I know it does on raw and JPEG files.
Photo of M Lavin

M Lavin

  • 7 Posts
  • 1 Reply Like
Yes, I tested it by exporting a .nef file to dng, and then re-importing the dng into lightroom. Some settings were saved, but not all.
Photo of Benjamin Warde

Benjamin Warde, Employee

  • 483 Posts
  • 72 Reply Likes
I am not able to reproduce this problem. My steps:

1. Select a raw file in Lightroom.
2. In the Develop module, add a spot-heal adjustment.
3. Export the file using the Export to DNG export preset.
4. Open the resulting image in Adobe Camera Raw.

Result: The spot-heal adjustment is visible.

Are your steps different? What version of Lightroom are you using? What operating system are you on?

Thanks,
Ben
Photo of john beardsworth

john beardsworth

  • 1021 Posts
  • 231 Reply Likes
You're not applying an import preset are you? It may be wiping those settings.
Photo of M Lavin

M Lavin

  • 7 Posts
  • 1 Reply Like
Hmm, the only difference from Benjamin's test is that I used the Hard Drive publish plugin to export the DNGs. Is there a reason that would not export all the metadata?
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 38 Reply Likes
Could it be that the LR/Transporter PlugIn was active at the time the published collection was created?

I had a similar problem with exporting originals
(no XMPs were exported). De-Activating LR/Transporter before creating the published collection solved the problem.

I've reported the bug to Tim Armes, but I don't think anything happened in this respect yet.

Beat
Photo of M Lavin

M Lavin

  • 7 Posts
  • 1 Reply Like
I'm not using the LR/Transporter plugin, just the standard Lightroom Hard Drive publish plugin. Is there a way to deactivate the Hard Drive plugin before creating the published collection?
Photo of Beat Gossweiler

Beat Gossweiler

  • 238 Posts
  • 38 Reply Likes
Well, was worth a try with LR/Transporter :-(

No, there is no HardDrive publish plugin, and nothing you can disable. Have you tried in a new catalog with a brand new publish collection?

Btw I just exported a changed Raw as DNG and re-imported the DNG into LR (LR 3.4.1, WinXP). I can see all the adjustments I made to the Raw (Exposure, Brightness, Blacks, Spot Healing, Local Adjustment Brush) on the re-imported DNG. What other options are you usind on export (i.e. compatibility)?

Beat

Beat
Photo of john beardsworth

john beardsworth

  • 1021 Posts
  • 231 Reply Likes
I'll ask again. Are you applying a Develop preset during the Import process.