Lightroom: Internal error occurred string ["PLService.lua"]:193: attempt to index field photos to export (a nil value) (Unable to export)

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
  • (Edited)
Trying to export an image to jpg. It would not export. Received error message as follows:
Internal error occurred
string ["PLService.lua"]:193: attempt to index field photos to export (a nil value)

(Unable to export) Then it repeats the message above: string ["PLService.lua"]... etc. etc.

Highlighted 1 image in "develop" mode to export. Clicked through the process to do that and received the error, repeatedly. I had just exported a copy of the same image with a different crop. Not sure why this is happening. Closed LR, then reopened but still export failed. Running LR 3.4.1 64-bit version. Thanks
Photo of DeborahG

DeborahG

  • 25 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of TinaC

TinaC, Tier 3 support engineer

  • 133 Posts
  • 11 Reply Likes
Official Response
Deborah, can you please open the Export dialog box, and in the Export to: pop-up menu at the very top, check to make sure Hard Disk is selected. If it is not, can you please let me know what is selected? Then change it to Hard disk and try exporting again.
thanks!
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14190 Posts
  • 1786 Reply Likes
Official Response
Here's the workaround/solution for this behavior:

Internal error occurs | Export photos | Lightroom 3