Lightroom: Export Actions no longer work on a Mac in LR 3.4

  • 2
  • Problem
  • Updated 12 months ago
  • Solved
  • (Edited)
By default, Export Actions, such as shell scripts, are placed in $HOME//Library/Application Support/Adobe/Lightroom/Export Actions

In LR2.7 these worked fine. After upgrading to LR3.4 they no longer work. I get the following error in the System Console:

15/05/11 12:06:44 PM [0x0-0xda0da].com.adobe.Lightroom3[3884] sh: /Users/andrewtj/Library/Application\ Support/Adobe/Lightroom/Export\ Actions/ No such file or directory

After doing some testing, I have found that the spaces in the path are causing it to fail. If I put the shell script in a folder that has no spaces and instead use "Open in Other Application" which lets me choose a non-default location for the script, it all works.

This needs to be fixed.
Photo of A TJ


  • 14 Posts
  • 3 Reply Likes
  • annoyed

Posted 7 years ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13637 Posts
  • 1548 Reply Likes
Official Response
Fixed in Lightroom 4 and later.