Photoshop CC 2015: 'Export as' not working - empty/blank dialog

  • 21
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
Attempting to export assets via the new 'Export as' option in the newly updated Photoshop 2015 but all i get back is a blank screen. I've seen it work on a colleagues computer just doesn't work on mine.

Any ideas?

I've rebooted my computer and even re-installed PS.

Photo of Marc Humphries

Marc Humphries

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 21
Photo of Divya Manian

Divya Manian, Employee

  • 82 Posts
  • 9 Reply Likes
Hi Marc, do you have a proxy running? If that is the case, can you get your proxy to not handle local addresses? You can check that setting here https://cloudup.com/cNDadFD1tC9
Photo of Marc Humphries

Marc Humphries

  • 3 Posts
  • 0 Reply Likes
Thanks Divya, we do have a proxy but I already have these settings in place.
Photo of irina maderych

irina maderych, Employee

  • 38 Posts
  • 5 Reply Likes
can you try checking "Exclude simple hostnames' in proxy settings?
also check if Enable Generator is checked in Preferences->Plugins
Photo of Marc Humphries

Marc Humphries

  • 3 Posts
  • 0 Reply Likes
Thanks Irina, it was the 'Exclude simple host names' that sorted it. Cheers, Marc
Photo of vejdi

vejdi

  • 1 Post
  • 0 Reply Likes


OS X Yosemite 10.10.1 / NVIDIA GeForce GT 750M

proxyı am using also Internet disable

the results did not change Solution ? thanks
Photo of irina maderych

irina maderych, Employee

  • 38 Posts
  • 5 Reply Likes
Can you try if checking "Allow Extensions to Connect to the Internet" fixes it? (Export Assets does not connect to Internet but connects to localhost)
Photo of Allister Payne

Allister Payne

  • 1 Post
  • 0 Reply Likes
I've attempted all the above solutions to this problem but no success so far. Has there been any further development or insight into a solution on this that someone could provide?
Photo of irina maderych

irina maderych, Employee

  • 38 Posts
  • 4 Reply Likes
can you email me generator log? imaderyc@adobe.com
generator log should be here: 
Macintosh HD ▸ Users ▸ {your user name} ▸ Library ▸ Logs ▸ Adobe ▸ Adobe Photoshop CC 2015 ▸ Generator
Photo of Michelle Worrell

Michelle Worrell

  • 1 Post
  • 0 Reply Likes
I'm getting this error while trying to export images with transparency. If I duplicate the layer so items are less transparent, then the Export dialog will refresh and show that there is content. I can then go back and delete the duplicated layer and the export function will work as it should. But if I only have a single layer that is semi-transparent, it won't do it until I do this step.

I am using a proxy, but all the settings match.
Photo of irina maderych

irina maderych, Employee

  • 38 Posts
  • 5 Reply Likes
Michelle, could you email me your PSD file so we can take a look? the one where export doesn't work, before adding duplicated layer? imaderyc@adobe.com

thanks!
Photo of Ned Thompson

Ned Thompson

  • 5 Posts
  • 0 Reply Likes
I'm also having the same issue. All I did was a create a folder with a circle vector mask and then placed a shape in that group. When I go to Export As, all I get is a blank screen. even if I just delete the vector mask and keep the shape, I still get a blank screen. I'm using Windows 7 by the way.
Photo of irina maderych

irina maderych, Employee

  • 38 Posts
  • 4 Reply Likes
could you try saving document and then export? If it still doesn't work, could you email me generator log file? (info where to find this file and my email above)

ETA: on Win, generator log is at   C:\Users\<username>\AppData\Roaming\Adobe\Adobe Photoshop CC 2015\Generator\logs

thank you!
(Edited)
Photo of 锡全 黄

锡全 黄

  • 5 Posts
  • 1 Reply Like
I had this problem before too.I solved it by delete the entries about adobe at C:\Windows\System32\drivers\etc\host
so,have a try and good luck.
Photo of Walt D

Walt D

  • 1 Post
  • 0 Reply Likes
I too am having this issue with the blank "Export As" dialog. (Also, the "Quick Export" doesn't do anything, no matter what format I set it to.) I'm running the new 2015.1 version of Photoshop on Windows 10 64-bit with 64-bit Photoshop.

I have tried resetting my preferences and reinstalling Photoshop. I am not using a proxy. None of the PSDs (or any other kind of image file) I've tried work.

Here's my generator_latest.txt file. It looks like there are some errors, but I don't know what to do about them.

-----

Log file created on Sat Dec 12 2015 14:56:51 GMT-0800 (Pacific Standard Time)

[debug:core 14:56:51.680 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:105:17] Launching with config:
{}
[info:core 14:56:51.769 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:223:25] Detected Photoshop version: 16.1.0
[1;31mPotential problem with plugin at 'C:\Program Files\Common Files\Adobe\Plug-Ins\CC\Generator\crema.generate': The plugin crema is incompatible with this version of generator-core. generator-core version: 3.5.0, plugin compatibility: ~3.4
[0m[1;31mPotential problem with plugin at 'C:\Program Files\Common Files\Adobe\Plug-Ins\CC\Generator\preview.generate': The plugin adobe-preview-generator-plugin is incompatible with this version of generator-core. generator-core version: 3.5.0, plugin compatibility: ~3.4.0
[0m[1;31mNo viable plugins were found in 'C:\Program Files\Common Files\Adobe\Plug-Ins\CC\Generator'
[0m[1;31mNo viable plugins were found in 'C:\Program Files\Adobe\Adobe Photoshop CC 2015\Plug-ins\Generator'
[0m[debug:core 14:56:51.801 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:1751:21] Loading plugin: generator-assets
[debug:core 14:56:51.943 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:1767:21] Plugin loaded: generator-assets
[debug:core 14:56:51.945 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:1751:21] Loading plugin: generator-spaces
[debug:core 14:56:52.051 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:1767:21] Plugin loaded: generator-spaces
[info:generator-spaces 14:56:52.054 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Plug-Ins\Generator\spaces.generate\main.js:36:20] Starting websocket server...
[warning:core 14:56:54.509 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:124:25] Photoshop error Pipe error: Error: EPIPE, read
[info:core 14:56:54.512 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:119:25] Photoshop connection closed
[info:core 14:56:54.515 C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\Generator-builtin\lib\generator.js:119:25] Photoshop connection closed
[1;31mExiting with code 0: Generator close event
[0m
Photo of Glenn

Glenn

  • 2 Posts
  • 0 Reply Likes
I've got the same problem after the 2015.1 update. It was working fine before that.

No matter which PSD file I use, the "Export As" screen is completely blank, and "Quick Export as PNG" does nothing at all.
Photo of Glenn

Glenn

  • 2 Posts
  • 0 Reply Likes
Seems it's fixed now with the 2015.1.1 update.
Photo of 锡全 黄

锡全 黄

  • 5 Posts
  • 1 Reply Like
I had this problem before too.I solved it by delete the entries about adobe at C:\Windows\System32\drivers\etc\host
so,have a try and good luck.
Photo of Justin Coolidge

Justin Coolidge

  • 36 Posts
  • 2 Reply Likes
it is NOT fixed with the 2015.1.1 because IT DOES THIS ON Photoshop 2015.1.2!!!
Photo of Vinny Troia

Vinny Troia

  • 1 Post
  • 0 Reply Likes
Same problem. Running Photoshop 2015.1.1

Proxy - auto discovery off. No proxy set. Exclude simple hostnames is checked.
PS settings.
Enable Generator - OFF
Enable Remote - OFF
Allow extensions to connect - OFF
(see attached).

I have even tried disabling my internet so there is no connection.

Just curious, what possible reason would an export feature have to call out to the internet???

The export screen is always blank.
Photo of 锡全 黄

锡全 黄

  • 5 Posts
  • 1 Reply Like
I had this problem before too.I solved it by delete the entries about adobe at C:\Windows\System32\drivers\etc\host
so,have a try and good luck.
Photo of Ned Thompson

Ned Thompson

  • 5 Posts
  • 0 Reply Likes
The update from Creative Cloud seems to have solved my problem.

EDIT: I seemed to have encountered the problem again, although slightly different. And this is after I installed the updates from Creative Cloud. I'm using Windows 7.
Photo of 锡全 黄

锡全 黄

  • 5 Posts
  • 1 Reply Like
I had this problem before too.I solved it by delete the entries about adobe at C:\Windows\System32\drivers\etc\host
so,have a try and good luck.
Photo of Josiah Chaney

Josiah Chaney

  • 1 Post
  • 0 Reply Likes
Run as administrator worked right away for me!
Photo of 锡全 黄

锡全 黄

  • 5 Posts
  • 1 Reply Like
I had this problem before too.I solved it by delete the entries about adobe at C:\Windows\System32\drivers\etc\host
so guys,have a try and good luck.
Photo of Gerald Tesha

Gerald Tesha

  • 3 Posts
  • 0 Reply Likes
There are no adobe entries in that file ~in my case
Photo of sandro marcelo

sandro marcelo

  • 2 Posts
  • 0 Reply Likes
My photoshop is still with error , I have a PC and did everything what is described above and nothing !
Someone managed to solve ?
Photo of Gerald Tesha

Gerald Tesha

  • 3 Posts
  • 0 Reply Likes
I've managed to solve by simply updating the app through creative cloud
Photo of sandro marcelo

sandro marcelo

  • 2 Posts
  • 0 Reply Likes
Thank you Gerald , I will update everything here .
Photo of Christopher Neal

Christopher Neal

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop - Export As shows blank window.

I cannot export a photo from Photoshop. When I click on File -> Export -> Export As... , a window pops up but it's all blank and gray and has no functionality. This renders Photoshop useless for me.
Photo of Gerald Tesha

Gerald Tesha

  • 3 Posts
  • 0 Reply Likes
update the app to the latest release though creative cloud
Photo of Christopher Neal

Christopher Neal

  • 3 Posts
  • 0 Reply Likes
I've done that multiple times, no dice.
Photo of Shlomi Ben Atar

Shlomi Ben Atar

  • 1 Post
  • 1 Reply Like
Hi I have the same problem and i'm on the latest release. ummm... help?!
Photo of Lane Fujita

Lane Fujita

  • 1 Post
  • 0 Reply Likes
Having the same issue on a mid-2015 MacBook Pro running Photoshop CC 2015 version 20150529.r.88 x64.
Photo of Karlie Kirkaldie

Karlie Kirkaldie

  • 1 Post
  • 0 Reply Likes
I am also having the same problem; completely blank Export screen. I'm on OSX 10.9.5 and Photoshop CC 2015.1.2. Any solve for this?
Photo of Tod Albet

Tod Albet

  • 1 Post
  • 0 Reply Likes
This is a bug in the latest 2 releases. I reinstalled Photoshop CC 2015, 3 version prior and the export save as was working fine. After the update, it turn to white blank. I had support from India call me a few times asking for my system configurations, LOL
Photo of Jaber Pmr

Jaber Pmr

  • 1 Post
  • 0 Reply Likes
I am also having the same problem; completely blank Export screen. I'm on windows 10 and Photoshop CC 20160113r.335.x64 Any solve for this?
Photo of Jonas Madsen Rogne

Jonas Madsen Rogne

  • 22 Posts
  • 3 Reply Likes
I have a non-functioning Export panel as well. Save-for-web is still better than export, but unfortunately does not support artboards. I am forced to export as PNG from SFW, then open it and manually crop each artboard and use SFW. ARGH. I am trying to get work done here!

Panel is blank and just sais "processing" forever.


No proxy.
OS X 10.10.5
Using Photoshop 2015.0.0.

Updating to Phooshop 2015.1.2 doesn't seem to work. The offline installer at https://helpx.adobe.com/photoshop/kb/uptodate.html#CurrentVersion just sais "this installer is not applicable to you". It's the only updater I can find. Do I need a separate update to some other version first? What update file would actually work?

Note: It's a work machine, and I can't use the CC desktop application for updating as it doesn't work well with the way we distribute software (the whole CC model has been a bit of a problem – with hundreds of machines; 99% of machines still run CS6 for this reason even though we have CC licences. /rant.).

tl;dr: Two problems. 1. Crappy export window is bugged and not working (and SFW doesn't support artboards).  2. Update does not work. 2015.2.1 patch not applicable to 2015.0.0.
(Edited)
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 114 Reply Likes
Likely you can't install updates, even manually, because the IT person who installed the software disable them so that only they could patch the system. This is a configuration setting that can be chosen when the applications are deployed. Also, it seems that a number of the problems encounter here have to do with network security conflicts. May want to check with IT about proxies, firewalls, and other security items. 
Photo of Elaine Foster

Elaine Foster

  • 1 Post
  • 0 Reply Likes
I had this issue too. I just updated the software and it's fixed. 
Photo of Justin Coolidge

Justin Coolidge

  • 36 Posts
  • 2 Reply Likes
IT *DOES NOT* FIX IT!!! IT IS *STILL* A PROBLEM IN PHOTOSHOP 2015.1.2!!! STOP LYING!!!
Photo of Erick

Erick

  • 2 Posts
  • 0 Reply Likes
i use this https://youtu.be/6TRz-gNdQFg and forget export as and save for web