Photoshop CC: Slow on my Windows 7 system

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Executive complaint. As has been repeatedly reported regarding Photoshop CC, it is very slow. I do not have third party apps (mine is a corporate implementation) and have 1 special company specific font. The support people often say these are the issue. I have an HP PC - Intel(R) Core(TM) i5-2540M CPU @ 2.60GHz with 8588 Mb RAM. Having done all the help tips on Adobe and the user groups, Adobe support simply blames the user and the user's system. In 2001, I could work a 700mb file on the then current PS with under a GB of RAM more quickly. With the current Photoshop CC, it takes longer to render two words of type on a 3mb file. No matter how you slice this, it is not great. My current laptop is a new build with a freshly installed OS (Win7). The issue is Adobe's inability to listen to users who have complained for years about this without (apparently) considering a flaw with the application. As a project manager for user experience apps, the user doesn't get blamed for lags etc., there is a problem that needs to be resolved.

Please take a moment to consider the customer experience when issues arise. If the issues is repeated of the course of years (as this one has been), it is Adobe's responsibility to look at and resolve the issue. Even if it is third party apps or fonts, if it happens to enough users over the course of years, you should take the challenge to overcome the conflict.

Any contact:
Jeff Swanson
jeffswans111@gmail.com
(account under jeff.swanson@verizonwireless.com)
Photo of Jeff Swanson

Jeff Swanson

  • 4 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14549 Posts
  • 1893 Reply Likes
Are all operations slow? Or just typing in a text layer?
Photo of Jeff Swanson

Jeff Swanson

  • 4 Posts
  • 0 Reply Likes
Most all: Layer selection, tool selection, clicking a menu (ie - File/Edit etc), zooming, creating a selection, moving an object, Undo as well as type/text layers. Pretty much all operations lag no matter the type
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Try disabling font previews.

Then try disabling all third party plugins and extension panels.

The slowdowns we've seen in up to date copies of Photoshop have been due to bugs in video card drivers, bugs in third party plugins, or bugs in utility programs and third party applications.
Photo of Jeff Swanson

Jeff Swanson

  • 4 Posts
  • 0 Reply Likes
To be pointed, you evidently did not read my post. I have no third party plug-ins. If you can explain to me how to turn off the font preview via Edit>Preferences>Type, I'm listening. The options are: Use Smart Quotes, Enable Missing Glyph Protection, Show Font Names in English, Use ESC key to commit text, Choose text engine options (East Asian selected). No preview option to deselect.

As I'd noted in my original post, I've been down these roads. It's why my intent is NOT to troubleshoot....it has been to no avail....But to contact whomever manages executive relations in order to complain that the product performs poorly from past iterations and the answer you just gave above (which I had already advised I tried in my post) is the ONLY answer anyone gets.

My issue does not get solved by seeing years of the same answer being given, as you have just done. If you have an answer other than the one I already noted I've tried, but you opted to give me the same answer anyway, please advise.

Do not give me the same answer or advise it is my system (a new OS image/install). If this is your answer, this information must then be given to those whom manage executive relations.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
Type -> Font Preview Size -> None.

You have a performance problem on your system. But the vast majority of other users are not seeing such a performance problem, and we have not seen such a problem here at Adobe (anything we find gets fixed as soon as we can).

We have considered flaws in the application - and spent a lot of time looking for such problems (and fixing any we find). We also spend a lot of time helping customers find the cause of slowdowns on their systems, which almost always turn out to be outside of Photoshop itself.

All we can do is try to help you figure out the cause of the performance problem on your particular system. There is no systematic problem as you claim. And yes, the troubleshooting steps to help people find the cause on their system are pretty much the same -- because the causes of performance problems we have seen are pretty much the same: corrupt fonts, bad drivers, bad plugins, bad extension panels, and external apps/utilities. So we have to rule out each one at a time.
Photo of Jeff Swanson

Jeff Swanson

  • 4 Posts
  • 0 Reply Likes
1) "Type -> Font Preview Size -> None." This DOES NOT exist in my Type preferences. I'd thought I made that clear. See attached.

Let's start with this to resolve. However, since what my user experience shows, and your instructions state differ, there is a UI issue. Again, I design UI experiences. If you are providing instructions that are not consistent with my experience, then I'm not sure it yet can be determined as my system.

If we can resolve this, we will move to the next troubleshooting. You provided a number of issues that either don't apply or would need further instruction.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
I didn't say anything about the preferences dialog.

In the main application menu bar there is a menu called "Type", select that, then scroll down to the menu item "Font Preview Size", and in the submenu select the first item labelled "None".