Especially video related but also a lot of other issues with Lightroom 6.x

  • 1
  • Problem
  • Updated 3 years ago
I know that this is not very constructive feedback but what is going on with Lightroom. Lightroom 6 feels a lot worse in terms of speed and stability compared to v5. I do love the face recognition but apart from that every 6.x release fixed a small number of bugs but also created a lot of new issues. Videos have never been a strength of Lightroom but it also should not get worse with every update.

Since 6.3 I cannot reliably export (via Publish Services) and import videos. I always had issues when browsing through my library with the preview images of videos not refreshing and hanging. But now every second import and export hangs and does not proceed when encountering a video. I haven't found a workaround yet for this issue yet. Hope you can help.

Also after using Lightroom for more than one hour it starts behaving weird. Telling me metadata of my images are out of sync, the interface is not reacting to export commands at all and finally I have to restart it, if it hasn't crashed yet.

It feels like the missing competition from Aperture did not do Lightroom a favor.
It sad but it does not make fun anymore to use Lightroom.
There are so many seemingly unrelated issues but I hope you can fix them so that I can start using Lightroom again.

BTW: I am using Lightroom with Mac OS 10.11.1 on a 2014 Macbook Pro 15".
Photo of Andreas Prantl

Andreas Prantl

  • 13 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4108 Posts
  • 1469 Reply Likes
There are some video investigations going on in another thread, which you might like to get involved with: http://feedback.photoshop.com/photosh...