Photoshop: Errors switching tools with keyboard shortcuts (alt key down?)

  • 2
  • Problem
  • Updated 7 months ago
  • (Edited)
I have used keyboard shortcuts for years without trouble, but my experience with recent versions of photoshop shortcuts are nearly unbearable. Frequently when I try to switch between the brush tool and the eraser, or to the healing tool, or the stamp tool, photoshop will simply 'ding' at me with an error sound. It dings at me when I try to change the brush size. Other times, it won't ding, but it also won't change tools. It regularly seems to think I'm holding the 'alt' key and keeps opening top menus when i try to select a tool. I press escape and try again, but it's still convinced I'm using 'alt'. It gets stuck in the layer style drop-down so that as I try to nudge the image, it just changes the layer style instead. I have to press escape to get out of that. My keyboard has become an incredibly unhelpful tool in photoshop, which is the exact opposite of what it's been for years. BTW, i recently replaced my keyboard, but was having the problem before that as well. It's NOT my physical keyboard.
Photo of Mark Halvorson

Mark Halvorson

  • 1 Post
  • 0 Reply Likes
  • frustrated as all heck

Posted 7 months ago

  • 2
Photo of Jerry Syder

Jerry Syder

  • 497 Posts
  • 226 Reply Likes
Yup, same here on Windows 10 and yup, this has been happening for some time. I think there are other threads on the same topic and I have no clue why this is taking so long to get resolved. There's no pattern to it but it will happen(the menus get highlighted as if one pressed ALT) when switching tools using the keyboard shortcuts. 
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Howdy Mark and Jerry,

What's your setup?  This is news to me and I can't reproduce what you're seeing.  Given that I heavily use PS, particularly shortcuts when changing tools, my guess is that there's at least one more ingredient to this problem.  Are you using a tablet, by chance?  Keyboards are set to English, right?  Do you have any companion or side-car apps that work off of ALT?  The menu becoming highlighted would indicate a collision of keystrokes, probably from a secondary source...  Similarly, the "ding" implies you've activated an illegal combo.

Are you able to reliably reproduce this issue?

Thanks,
David
Photo of Jerry Syder

Jerry Syder

  • 497 Posts
  • 226 Reply Likes
Hey, David. Weren’t these issues brought up before? Windows issues when switching tools. For example, you’d be using the brush then switch to eraser, then back to brush, only to realise that the clone stamp too is selected. Or, you may use Alt, in conjunction with other keys as part of a KBSC or Action and because Alt was pressed, it highlights the menus and one must press escape. English keyboard and Wacom tablet plugged in. No sidecar apps reliant on Alt that I’m aware of. I’d try to find a recipe when I’m sat behind the computer but these are just off the top of my head at the moment.
Photo of David

David, Official Rep

  • 3602 Posts
  • 615 Reply Likes
Howdy Jerry,
Thanks for this information.  This is what I know...
There have been bugs with regard to when ALT is pressed, but that's a separate matter from tools changing.  All the Tool shortcuts are  limited to A to Z, no modifiers.  In the case of multiples with the same shortcut, there is a default and the others can be accessed in order by adding SHIFT.  A few tools shift to different tools when ALT or CTRL are pressed, but those are very specific.  Further, there are Spring-Loaded shortcuts that allow you to change from Brush to Eraser by clicking-and-holding the shortcut, with the tool changing back when released.  The scenario with the Clone Stamp tool that you mention shouldn't be possible.  So I see that as an issue.
There is a timing issue with ALT on Windows machines as part of the general Windows paradigm supporting the ADA.  If you press ALT, the Command Menus activate.  So, if you hit ALT too many milliseconds in advance of your shortcut, you fake out the Windows standard instead of getting the shortcut you wanted.  But that's a function of keyboards and settings as well as timing.
Finally, I hear users say "Wacom" and "shortcuts not working" a LOT.  And nearly every time, if the users tries without the tablet, the problem is gone.  I know that sounds like passing the bug, but if a problem seems to be contingent on a specific component, that's usually where the fix belongs.

If I'm wrong or misunderstood something, please let me know.  I really would like to get anything fixed that we can.
Thanks,David
(Edited)