Lightroom: Error opening Map and Book module

  • 1
  • Problem
  • Updated 8 years ago
  • Solved
  • (Edited)
Trying to open the Map module always gives an error message "?:0: attempt to call field 'hashHmacSha1' (a nil value)".
Similarily trying to open the Book module always gives the error "Could not run script: BookModuleFactory.lua Error: ?:0: attempt to call a nil value"

I'm using Lightroom 4 on an Windows 7/64 bit system.
Photo of Basti


  • 7 Posts
  • 0 Reply Likes

Posted 8 years ago

  • 1
Photo of jdv

jdv, Champion

  • 728 Posts
  • 56 Reply Likes
This looks like Lightroom is not installed properly, or something is not letting the app find its own files. For some reason it can't find Locations.lrmodule or Book.lrmodule, or can't open these modules up and get resources from them.

Try disabling all real-time AV protection, if you have that enabled. Try running Lr from a new account with admin privileges.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2368 Reply Likes
Do you have any 3rd party add ons/plug-ins/scripts installed?
Photo of Julie Kmoch

Julie Kmoch, Sr. Development Manager

  • 109 Posts
  • 43 Reply Likes
John's theory is as good as anything we've come up with on the team. These are not errors we've seen before and it does suggest it's not finding code for some reason. Please let us know whether his suggestions are helpful.
Photo of Basti


  • 7 Posts
  • 0 Reply Likes
Hey, thanks for the replies! It actually was a clean install after a fresh install of Windows on a revamped system. No 3rd party add ons were installed. However, as the deinstall ran into problems removing the files I assume that indeed LR didn't install properly. After resetting all read-only attributes of all files inside the LR directory I could rerun the deinstallation somewhat successfully - quite a couple of files were left, so I removed them manually.
After that I installed LR again and voila: it seems to work :-)

Thanks for your help! Keep up the great work!