Lightroom: Error in deletePhotosfromPublishedCollection: did not call deletedCallback function

  • 1
  • Problem
  • Updated 7 years ago
  • Solved
  • (Edited)
Hi, in a LR publishing service, when it comes to the deletion of images that were removed from the collection, it halts with the following error message:



I have found several reports of this happening when the file to be removed from the collection had already been removed manually outside of LR. But this is not the case with me - the file still exists on the hard drive.

I rather believe that it can't handle the # character in file names properly, because the file's name is e.g. 2011-03-27_00-51-50_#165.jpg, but when I right-click on the image in LR and select "show published file in Explorer" it telles me it can't find the image but with the name "S:\\165.jpg, so the part of the file name until the # is missing! This happens to all the files that have the # in their name.

I am using Windows 7 64 bit, if that matters.

# is an allowed character in filenames in any modern OS, so please fix this annoying bug as soon as possible.

It seems to have been introduced in LR 3.4 or 3.4.1, as I haven't encountered it before, and the # is in almost all my images as it is important for my workflow.

Any ideas for workarounds (other than renaming the files!!!) are also very welcome!
Photo of DarkVater

DarkVater

  • 46 Posts
  • 1 Reply Like
  • annoyed

Posted 7 years ago

  • 1
Photo of DarkVater

DarkVater

  • 46 Posts
  • 1 Reply Like
Official Response
I have just installed LR 3.5 RC1 and it seems that the issue has been resolved. Many thanks!