Lightroom: Error messages after upgrading to 6.3 from 6.2.1

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Just updated Lightroom 6.2.1 to 6.3 and now getting popup that says "Could not run script: LibraryFactory.lua", followed by "assertion failed!" after replying OK to first popup. Lightroom then gives me a blank (grey) screen. If I click on Library then I see my photos. Lightroom appears to be working now but these messages worry me. I'm running Windows 10.
Photo of Gary Coffman

Gary Coffman

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 1
Photo of Gary Coffman

Gary Coffman

  • 1 Post
  • 0 Reply Likes
Please respond . . .
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Hi Gary, it sounds like a damaged install issue. http://feedback.photoshop.com/photosh...

I would uninstall and reinstall.
Photo of Gary Coffman

Gary Coffman

  • 1 Post
  • 0 Reply Likes
Thanks for the reply, I can try reinstalling. I had purchased and applied the upgrade to Lightroom 6 (from Lr 3), and then upgraded to 6.2.1 which ran clean. Only after applying the 6.3 upgrade did I see these messages.

I'll reply back here with results . . .

Thanks,
Gary
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
Thanks.