Photoshop: Error 21 with update to CC 2015

  • 11
  • Problem
  • Updated 5 years ago
  • In Progress
  • (Edited)
I get these errors in trying to update PS2015...Other CC Photoshop programs do update. Installed PS 2015 originally but now cannot up date it.ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 11
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16857 Posts
  • 2828 Reply Likes
Did you install the updates from the Creative Cloud update? Or did you download patchers directly and run them?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16857 Posts
  • 2828 Reply Likes
Also, what OS/version are you running on?
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Win7-64bit, SP1
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
I was in CC and clicked update for 2015...installed up to 42% and then got the Error 21 message...Frank
Photo of Stephen Ciauri

Stephen Ciauri

  • 3 Posts
  • 1 Reply Like
Same thing.

- Downloaded from Adobe CC
- OSX Yosemite 10.10.3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16857 Posts
  • 2828 Reply Likes
Very strange. If you completely restart the system ad try the updates again, does it work?
Photo of Rolf Moser

Rolf Moser

  • 10 Posts
  • 0 Reply Likes
I have the same error (OS win 8.1 64 Bit)

ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included
Photo of Pete Green

Pete Green, Customer Advocate

  • 780 Posts
  • 166 Reply Likes
We have a log collector tool -- helpx.adobe.com/creative-cloud/kb/cc-log-collector.html

Could those with this issue, use the collector tool and email me the .zip files you get?

petgreen [at] adobe [dot] com
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16857 Posts
  • 2828 Reply Likes
If you go to the Creative Cloud app and click the gear icon in the upper right and choose Preferences... what does the version say?

The most current version should be: 2.1.1.110
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 123 Reply Likes
What version of the Creative Cloud desktop app do you have installed? Make sure this is fully up to date. The version should be 2.1.1.110. If you don't have this latest version installed, sign out of and back into the desktop app: https://helpx.adobe.com/creative-clou...
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 123 Reply Likes
If sign out/sign in doesn't cause the desktop app to update, try Solution 2 here: https://helpx.adobe.com/creative-clou...
Photo of Rolf Moser

Rolf Moser

  • 10 Posts
  • 0 Reply Likes
My creative cloud version is the actual version 2.1.1.110.
(German Version)

I also tried to delete the "opm.db" (your solution 2) and I made a new login to Creative Cloud.

Once more Photoshop CC (2015) has been completely downloaded by CC. Then it shows message "Extrahieren" (German message for Extraction) then by the Installation message it stops at 43% with "Installationsfehler" (error installation)

more information:
"ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS"

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

Same error as before!

Must I have to uninstall the Photoshop CC (2014) version?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16852 Posts
  • 2825 Reply Likes
No. Uninstalling the Photoshop CC (2014) version shouldn't affect this. Please send your log files to Pete Green (his post/instructions are above)
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Where do I find the log files? Thanks for the help...Frank
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16852 Posts
  • 2825 Reply Likes
Use this tool to collect them: http://helpx.adobe.com/creative-cloud...
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Ok...I have the log file...How do I sent it to you? Doesn't seem to be a way to add a file or folder (e.g., desktop folder) to these replies...Frank
Photo of Stephen Ciauri

Stephen Ciauri

  • 3 Posts
  • 1 Reply Like
These steps worked for me:

1) Log out of CC
2) Reboot machine
3) Log in to CC
4) Update CC (Should begin automatically upon login)
5) Install PS CC 2015
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16852 Posts
  • 2825 Reply Likes
Did you every try just signing out and back in (without the reboot)?
Photo of Stephen Ciauri

Stephen Ciauri

  • 3 Posts
  • 1 Reply Like
I did, but the update hung at 0% and made no progress.
Photo of Brian Yoder

Brian Yoder

  • 2 Posts
  • 4 Reply Likes
All 2015 apps installed properly EXCEPT Photoshop. It repeatedly gives the following error at 42%: (Win 8 x64) Tried above no change...

Exit Code: 21
Please see specific errors below for troubleshooting. For example, ERROR: DW021 ...

-------------------------------------- Summary --------------------------------------
- 0 fatal error(s), 3 error(s)

ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

-------------------------------------------------------------------------------------
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
NO EASY FIX FROM ADOBE....I spent 2.5 hours online with Adobe Technical Assistance this evening. The person tried everything and finally gave up. He suggested deleting ALL Adobe CC items and trying a clean install once all Adobe CC references were gone. He is going to send me an email outlining the step. But this sure is frustrating since PSCC 2014 works and LR CC 2014 works.
Photo of Alan Macaulay

Alan Macaulay

  • 1 Post
  • 0 Reply Likes
I also have the same problem but still have no solution from Adobe. Tried making a new administrator account but still failed.
Photo of Rolf Moser

Rolf Moser

  • 10 Posts
  • 0 Reply Likes
I also still have the problem. So far, no solution is available from Adobe
Photo of Production Artist

Production Artist

  • 6 Posts
  • 1 Reply Like
I'm also having this exact same problem. All other 2015 apps updated just fine. Photoshop won't update no matter what I've tried (ie. logging out / rebooting / running Adobe Cleaner, etc.).

Running Windows 8.1 Pro.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16857 Posts
  • 2828 Reply Likes
Official Response
Please try the solution here to uninstall and reinstall the Creative Cloud desktop app: https://helpx.adobe.com/creative-clou...
Photo of Geoffrey Grierson

Geoffrey Grierson

  • 1 Post
  • 0 Reply Likes
This worked for me. The symptoms I had were that the update button (in the CC desktop) for PS CC 2015 didn't appear to do anything, on a MAC
Photo of DannyB

DannyB

  • 4 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled Photoshop CC 2015: Installer ERROR: DW021.

I can't install the latest Photoshop CC 2015. I just get this error:

Exit Code: 21

Please see specific errors below for troubleshooting. For example, ERROR: DW021 ...

-------------------------------------- Summary --------------------------------------

- 0 fatal error(s), 3 error(s)

ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

-------------------------------------------------------------------------------------



Any ideas [I've used the CC Cleaner tool to wipe it all and start again - no dice, and Illustrator CC 2015 installs as normal]?

Thank you!
Photo of Production Artist

Production Artist

  • 6 Posts
  • 1 Reply Like
I've run through the process noted and it does nothing to resolve the issue. Why would every single other CC app I'm using (Premiere / AE / AI / ID / etc.) all install without issue and Photoshop is having this problem?

I think I'll just revert everything back to the previous versions if I can. This is incredibly frustrating... for all of us experiencing this issue.
Photo of Production Artist

Production Artist

  • 6 Posts
  • 1 Reply Like
Here is the error...

Exit Code: 21
Please see specific errors below for troubleshooting. For example, ERROR: DW021 ...

-------------------------------------- Summary --------------------------------------

- 0 fatal error(s), 3 error(s)

ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

-------------------------------------------------------------------------------------
Photo of Ashutosh Nigam

Ashutosh Nigam, Employee

  • 22 Posts
  • 2 Reply Likes
Please Try this workaround and let me know if it works:
Rename this folder:
C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp to PDApp_old

Then install CC app by following steps as mentioned by Jeff:
https://helpx.adobe.com/creative-clou...

Do mail us the log files to asnigam@adobe.com or petgreen@adobe.com

Regards,
Ashutosh
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Did not work...Still get Error 21...Did the renaming of folders, except could not change Adobe in Program Files (x86).Windows said folder or file was open or in use elsewhere, but I had stopped it in startup and in services and run the uninstall program. Perhaps it will be best to just quit Adobe since nothing works to solve the problem after 2 days of trying with helpful suggestions.. There are alternatives.

What log files in particular and how can they be attached to a your email address?

Thanks for trying. Frank
Photo of Brett N

Brett N, Official Rep

  • 2260 Posts
  • 123 Reply Likes
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Thanks, I got this and tried it yesterday and today; Adobe Support also used it when they took over my computer, but neither they nor I could get it to solve the problem. Today the Adobe Support person forwarded my install logs to "senior staff" because he could not solve it at his level. Seems like the Error 21 problem is deep in the Adobe updater program. Last night's Adobe Support staffer concluded there is some "process" conflict in the updater. At that point, he gave up. So I assume Adobe's usual tools for update problems haven't be designed to deal with this new issue.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 860 Reply Likes
Normally that error would only come up if you tried to use a new installer with an older version of the CreativeCloud app (because the older version doesn't have the new installer support). If people have the new CreativeCloud app, then something is getting very confused, and they're still examine the log files to figure out what is going on.
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Thanks...It does sound like some mismatch in code between the installer and the CC app. In my case I have impression that the CC app was refreshed in the last month or so. But hard to tell at the user end exactly when we got a "new" app. Your comment tho points to the potential source of the issue so that should be helpful to Adobe staff. Thanks again.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 860 Reply Likes
The Creative Cloud app was updated twice in the past week. (check the preferences panel for it, it shows the version number, and you should have 2.1.1.110)
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes
Thanks-- that's the flavor of CC app on my machine...Frank
Photo of Thomas Splettstoesser

Thomas Splettstoesser

  • 1 Post
  • 0 Reply Likes
Thanks!
I had the same problem. Had already tried to re-install the CC app but Photoshop CC2015 would still not install. After I tried to rename the folder first and then re-installed the CC app, the installation finally went through. Thx
Photo of Kristin Wheeler

Kristin Wheeler

  • 3 Posts
  • 0 Reply Likes
Thanks. Had the same problem: ERROR: DW021: Payload. Following these instructions worked for me as well.
Photo of Adolf Satzinger

Adolf Satzinger

  • 3 Posts
  • 3 Reply Likes
I have the same problem
Photo of Raul

Raul

  • 2 Posts
  • 0 Reply Likes
I'm having same problem. Yesterday installed update for Lightroom and Photoshop and both programs crash at start. Unfortunatelly i delete and uninstall old versions. I try to install older version but they ask for serial numbers. Adobe dont have any answer for this?
Photo of Rolf Moser

Rolf Moser

  • 10 Posts
  • 0 Reply Likes
I have
-uninstalled Photoshop CC 2014
-uninstalled Creative Cloud with AdobeCreativeCloudCleaner Tool
All ADD Ons for Photoshop deinstalled
-Reboot
-try to new install CC from WEBsite

but Installation of Photoshop 2015 has the same problem :
ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

Once more
OS is WIN 8.1 x 64 Prof. German Version
Installation of German Version of CC

I'm at a loss. Because no one knows a solution to the problem?