Photoshop: Error 21 with update to CC 2015

  • 11
  • Problem
  • Updated 3 years ago
  • In Progress
  • (Edited)
I get these errors in trying to update PS2015...Other CC Photoshop programs do update. Installed PS 2015 originally but now cannot up date it.ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included
Photo of Frank Sobol

Frank Sobol

  • 16 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 11
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14046 Posts
  • 1734 Reply Likes
Official Response
Please try the solution here to uninstall and reinstall the Creative Cloud desktop app: https://helpx.adobe.com/creative-clou...