Photoshop/Lightroom: Error 183 when updating CC Desktop from the Assets tab

  • 1
  • Problem
  • Updated 2 weeks ago
  • In Progress
  • (Edited)
Hi,

Today, Adobe CC Desktop refused to start telling me that I either had to Quit or to Repair. I selected Repair which resulted in a failed operation and an empty folder for the CC Desktop app. Thank you, Adobe. So, as usual, I uninstalled and reinstalled CC Desktop. After launching it, I saw a red dot near the Assets tab. I clicked on it and after "Checking for updates...", it proposed to update Adobe CC Desktop ( ? ? ? I had just downloaded and re-installed it so I'm wondering what it wanted to update).

Anyway, this operation systematically fails with either error 184 or error 183. Log file here : Dropbox - Install.zip . I'm using Windows 10 Creators. I tried in Safe Mode and under a clean Admin account, with and without AV running. Nothing helps.

This program is just a failure. Always new problems, failed updates, uninstallations and re-installations,... I can't spend my time uninstalling / re-installing / cleaning up the Adobe CC stuff each time Adobe CC Desktop is updated. This doesn't make sense. The developers of this program should spend their time fixing it (or rather rewriting it because it never worked correctly).

Details about these 2 errors :

Error 184


FATAL: Error (Code = 184) executing in command 'MoveFileCommand' for package: 'CoreSync-mul', version:2.4.1.35

FATAL: Error occurred in install of package (Name: CoreSync-mul Version: 2.4.1.35). Error code: '184'

WARN: Unable to move file at "C:\adobeTemp\ETR233F.tmp\1\CoreSyncExtension\CoreSync_x64.dll" to "C:\Program Files (x86)\Adobe\Adobe Sync\CoreSyncExtension\CoreSync_x64.dll" Error 32 The process cannot access the file because it is being used by another process.. Try setting correct permissions to the specified file/folder or parent folder, so that admin has rights to modify it.

Indeed, if I kill the Windows Explorer process while the update is running, I don't get this error but I immediately switch to error 183... It's rather strange that the updater is trying to update a DLL that is already in use by Explorer.exe.

Error 183


FATAL: Error (Code = 183) executing in command 'RunProgramCommand' for package: 'CoreSync-mul', version:2.4.1.35

FATAL: Error occurred in install of package (Name: CoreSync-mul Version: 2.4.1.35). Error code: '183'

WARN: Program "C:\Program Files (x86)\Adobe\Adobe Sync\CoreSync\customhook\CoreSyncCustomHook.exe" failed with exit code: 105

This one is unclear. No idea about what RunProgramCommand is trying to do.
Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes
  • upset

Posted 2 years ago

  • 1
Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes
Hi,

An old problem that I already reported here https://forums.adobe.com/thread/2591737 appeared again today when trying to update to version 4.8.1.435 of Adobe CC Desktop.

When the Creative Cloud update was proposed, I clicked on Install and the process reached 100%. Then the installer window suddenly disappeared and that was it. But I now have a lot of experience with this calamitous installation process and I immediately had a look at the C:\Program Files (x86)\Adobe folder. No surprise : I could see that the new version was actually installed but the folder named Adobe Creative Cloud_4.8.1.435 could not be renamed and the old one - containing the previous version - could not be deleted (see screen capture in above mentioned thread - same problem, only the version number is different) .

So, as usual again, I killed all Adobe related processes, restarted a new Windows session, renamed (as quickly as I could) C:\Program Files (x86)\Adobe\Adobe Creative Cloud to C:\Program Files (x86)\Adobe\Adobe Creative Cloud.old and C:\Program Files (x86)\Adobe\Adobe Creative Cloud_4.8.1.435 to C:\Program Files (x86)\Adobe\Adobe Creative Cloud. And I could eventually run the Creative Cloud desktop app.

Rikk,

The Adobe CC Desktop version - 4.7.0.400 - that came after your message above (7 months ago - "they've identified the issue") didn't have this problem. It re-appeared with version 4.8. So it seems that someone managed to re-incorporate the bug in the most recent versions.






Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes
Problem still there with version 4.8.2.476.

Same comments as above. Just replace 4.8.1.435 with 4.8.2.476

This will never end, I'm afraid.
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5496 Posts
  • 1157 Reply Likes
@Patrick Philippot - you will have better luck with Creative Cloud App issues at this support area: https://creativecloud.uservoice.com/ 

Have you posted the information there previously?  It is a similar forum but specializes in the CC App and reporting issues with it. 
Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes
I was not aware of this forum. Thanks.

I have posted a report.
Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes
https://creativecloud.uservoice.com/

Not much activity there (understatement), I'm afraid.

Actually, the organization of customer support at Adobe is very strange :

- A lot of forums (forums.adobe.com powered by the terrible Jive software) where reporting is almost useless since you are told that it's a user to user forum, so no Adobe representative is expected to answer. Users cannot fix bugs. ACPs do sometimes answer but they keep repeating the same recipes : reset preferences, uninstall, clean, reinstall, and the like... We have already discussed this. This will never help permanently fix problems. This is just a temporary workaround (when it works).

- A "real" feedback forum (Photoshop Family) dedicated to PS and LR only. Bugs reported there are handled randomly. Some are 6 or 7 years old or even older, some are closed while they are not solved, they are not assigned to a particular developer (which is the only way to make some progress,),... 

- A dedicated CC forum that is not advertised anywhere and consequently where nothing seems to happen (Desktop app : 9 posts; Mobile app : 0 post; Web app : 82 posts).

What else ? Opening a case ? Calling the support ? Most of the time, it's useless because the support personal generally doesn't even understand what you're saying.

The only efficient way to organize support is to have a unique place where you can, by product, post bug reports, share experiences, list acknowledged bugs and see their current status, see who is in charge, etc. That is, a professional bug reporting system. Obviously, Adobe are unable to setup such a system, which is surprising, to say the least. This gives the feeling that nobody is actually in charge of this service at Adobe.