Photoshop: Erroneous selection artifacts appear when using Select Color Range and Polygon Lasso Tool

  • 1
  • Problem
  • Updated 3 days ago
  • Solved
  • (Edited)
I was editing a photo in Photoshop 21.0.1 using the "Select Color Range" tool, the "Rectangular Selection" tool, and the "Polygon Lasso" tool to select / isolate an irregular area that I wanted to adjust.  While refining the selection created by the "Select Color Range" tool several instances of an artifact that looked a lot like a boot appeared at various locations in the image and outside the area that had been selected.  I tried to remove these artifacts by using the "Rectangular Selection" tool set to remove or "-" the area marked.  That did not remove them.  Later I tried to remove small portions of each artifact which did work if I used 4 or 5 selections to do the removal.  I have managed to get the selection artifacts out of my selection.  I'm thinking that there may be some sort of memory usage conflict causing this problem.  Most of the artifacts appear in the area above the light colored sky in the uploaded image.  System is Windows 10 Home Premium with all updates installed.


Photo of Bill Junk

Bill Junk

  • 89 Posts
  • 6 Reply Likes
  • frustrated by so much time wasted.

Posted 4 days ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16089 Posts
  • 2531 Reply Likes
I'm not sure if that's erroneous. It looks like you're trying to use Color Range on the mask of the adjustment layer. If you select the bottom layer does Color Range work as expected?
Photo of Bill Junk

Bill Junk

  • 89 Posts
  • 6 Reply Likes
There were some other strange things happening as well, so I uninstalled Photoshop and reinstalled it.  I've redone the selection that I'd been working on before the "artifacts" showed up and I think I did it in the same way as before.  It's been less than an hour but things now seem to be better.  Time will tell.  Thanks for the quick reply and suggestion.
Photo of Bill Junk

Bill Junk

  • 89 Posts
  • 6 Reply Likes
After reinstallation of Photoshop all features appear to be working as expected. Must have been something corrupted during or post installation.
Photo of Bill Junk

Bill Junk

  • 89 Posts
  • 6 Reply Likes
After reinstallation of Photoshop all features appear to be working as expected. Must have been something corrupted during or post installation.