Photoshop: Painting on mask stopped working in CS4

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
  • (Edited)
Eraser tool has stopped working in Photoshop CS4. Used the program a couple weeks ago, worked fine. This week, its not working. I tried restarting program (which has worked in the past when it would occur), restarting computer. I reset the brushes. Still doesn't work. What might the problem be? what may fix this?
Thank you
Photo of Laura Logan

Laura Logan

  • 9 Posts
  • 2 Reply Likes

Posted 6 years ago

  • 1
Photo of Pete Green

Pete Green, Customer Advocate

  • 699 Posts
  • 126 Reply Likes
Photo of Laura Logan

Laura Logan

  • 9 Posts
  • 2 Reply Likes
I did that already. it didn't correct the problem.
Photo of Pete Green

Pete Green, Customer Advocate

  • 687 Posts
  • 115 Reply Likes
In that case, perhaps a pref restore will fix this: http://helpx.adobe.com/photoshop/usin...

If you do this and still have trouble, let us know
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13968 Posts
  • 1664 Reply Likes
When you say "Stopped working" what is the behavior? Do you get an error? do you click and nothing happens? or do you click and something unexpected happens? (E.G. paints with black or another color)
Photo of Laura Logan

Laura Logan

  • 9 Posts
  • 2 Reply Likes
Thank you for your help. The problem is fixed. In my mask layer, the background was switched to white..reset it, eraser works now.
Photo of Pete Green

Pete Green, Customer Advocate

  • 687 Posts
  • 115 Reply Likes
Thanks for letting us know it's resolved Laura!