Enable filters will not work in LightRoom 5.4

  • 1
  • Question
  • Updated 4 years ago
  • (Edited)
All of a sudden Lightroom 5 will not enable filters. All filters remain grayed out. It worked yesterday but will only show zero photos when filters are enabled. The only new thing on my Mac Mavericks may have been an auto update to Mozilla Firefox. I removed Firefox and any files I could find, which weren't any (looks like the update did not take). I tried many things in Lightroom 5 to fix the problem, but it still will not enable filters. How can I fix this?
Photo of Mary Ramsey

Mary Ramsey

  • 3 Posts
  • 0 Reply Likes
  • frustrated.

Posted 4 years ago

  • 1
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2647 Posts
  • 337 Reply Likes
Filters are relative to your current folder/collection. If you click on the built-in All Photographs collection, do filters become available, then?

Approximately many photos do you have in your catalog?
Photo of Mary Ramsey

Mary Ramsey

  • 3 Posts
  • 0 Reply Likes
Thank you for the reply. I am using a Mac Mavericks. I have a 4,200+ photos in the Lightroom catalog. Interestingly, when I click on "All Photographs" under Catalog on the left side of the screen and I enable filters, 15 photos filled the filmstrip at the bottom of the window and that is all. Hundreds should appear in the bottom filmstrip.

When I am in a specific folder (on the left side of the Lightroom screen) and I click Enable Filters, all photos disappear. The filters are NOT set to "none" in the rating, they are set to 2 or more stars.

This only started happening yesterday and I think it may have something to do with a web browser. I downloaded Firefox because Safari would not open a website I wanted to use. It just kept saying Safari was not connected to the internet when I tried to access that website. Yesterday morning Firefox seemed to have a problem (a ? appeared on the dock in place of the Firefox symbol) so I removed Firfox and hopefully all of its files. Safari started opening the website I could not open before and Lightroom stopped sorting by ratings when I enabled filters. Not sure when Safari was able to open the website as I did not try it before I trashed Firefox.

I thought I'd try removing Lightroom 5 and then reinstall it since I can't find a fix. Any thoughts you have a greatly appreciated.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2647 Posts
  • 337 Reply Likes
So you are using the Filter area at the bottom right just above the thumbnails.

What happens if you use the more detailed filter bar at the top of Library? Go to Library, then select All Photographs, and press the backslash (\) key to enable the filter bar if needed.

First look to see that the padlock symbol at the upper right isn't engaged, then click the dropdown list next to the padlock and choose Rated. Do things look ok, then?

Now click the 1 star to turn that filter off, so then all the photographs should be visible, then click the 1 star to turn it on, again. Does it show the right number of photographs, now?
Photo of Mary Ramsey

Mary Ramsey

  • 3 Posts
  • 0 Reply Likes
No, I am not using the filter area that the bottom right to enable the filters. I had already gone through each photo in a specific folder and rated the photos I want to filter (star ratings on certain photos). I am using the Menu at the top of the computer screen under Library/Enable Filters/Filter by rating. The "Filter by Rating" has the correct number of stars checked but it always remains grayed out since the problem started. When I put a check mark next to Enable Filters, then all my photos in the filmstrip at the bottom of the screen disappear and no photos have been selected by enabling the filters.

Your directions above- Do you mean at the top of the screen go to Edit and select "Select All"? I don't see any "All Photographs" under Library. (I do select all photos when filtering).

Ummm... it just worked! I went to the bottom right of the screen and changed "Filters Off" to "Rating" and voila only the rated photos appeared. :-) And now under Library/Ratings t the top of the screen, the ratings are no longer grayed out!! I never used filtering from the bottom of the screen before.

I can't thank you enough for your help. I've spent hours trying to figure out how to solve this and couldn't find any information on it. As you probably figured out by now, I only know the very basics of Lightroom. I plan on upgrading my knowledge this year; I obviously need to do that. I appreciate that you took the time to help me. Once again, thank you so very much, Steve.

Mary
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2647 Posts
  • 337 Reply Likes
All Photographs is the special Collection at the top left. I just wanted to make sure you were not in some subfolder and didn't have another collection selected.

At least you got it working. I wonder if there was some corrupted filter-query data saved somewhere that reselecting things at the bottom right reset.