Elements organizer 12 won't launch on MacOS 10.6.8 (requires 10.7)

  • 1
  • Problem
  • Updated 5 years ago
  • Not a Problem
  • (Edited)
I have a Mac (OS X 10.6.8) and purchased and installed Elements 12 from the Adobe website in November 2013. Organizer will not launch. I tried cmd+shift+option while launching but nothing happens (just closes). I have reloaded Elements 4 times. Loaded it once with Elements 10 installed and 3 after I uninstalled Elements 10.

I have not been able to find a solution. How to do fix this? (error message below)

Dyld Error Message:
Library not loaded: /usr/lib/libcurl.4.dylib
Referenced from: /Applications/Adobe Elements 12 Organizer.app/Contents/MacOS/../Frameworks/dvacaptioning.framework/Versions/A/dvacaptioning
Reason: Incompatible library version: dvacaptioning requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0
Photo of Peter Layden

Peter Layden

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
Elements 12 requires MacOS 10.7 or later.

http://www.adobe.com/products/photosh...