Elements Organizer 12 Catalog Conversion Problem - Can't assign media to albums following conversion.

  • 1
  • Problem
  • Updated 4 years ago
Working on a Win XP SP3 machine. Upgrading from Elements 11 to 12

I have about 20,000 photos organized in my system.

After running the Catalog Conversion to Elements Organizer 12 I found that every attempt to assign media to an album failed with the following error, "Error applying keyword tag(s)".

I tried running the catalog repair tool. It reported "no errors," I chose repair anyway. Nothing changed, same errors

I created a new catalog in EO 12 and added several photos and albums to it. Assignment of these photos to albums worked flawlessly.

I decided to repeated the conversion process. The same error.

Next I reinstalled Elements 11 and loaded up the Elements 11 Catalog that I had just converted. It worked perfectly.

There just might be a problem with the catalog conversion routine in Elements Organizer 12.

Seems that I will be working in Elements 11 for a while longer.
Photo of Alice Tumblin

Alice Tumblin

  • 4 Posts
  • 0 Reply Likes
  • frusterate and tired of spending time trying to repair tools instead of working

Posted 4 years ago

  • 1
Photo of Vaishali

Vaishali, Employee

  • 212 Posts
  • 13 Reply Likes

This is a known issue with Elements 12 and Elements team has prioritized it for fixing.
In the meantime, you can try the following workaround:

Make a new album in converted catalog. After this album creation, media can be associated successfully.

Let me know if this does not work with you.

Photo of Alice Tumblin

Alice Tumblin

  • 4 Posts
  • 0 Reply Likes
That worked.

Did I miss a "read me" or some other publication? I have burned many hours trying to solve this problem. It seems that it could have been easily avoided.

I would appreciate it if you mentioned to the powers that be that there are many people out here who do not share Adobe's fondness for script laden web sites and pages. We do not like to have everything we do tracked and recorded by multiple entities.

In order to use the page I am writing this on I had to instruct my script blocker to allow 12 or more scripts that I normally block and that are generally thought of as untrusted.


Photo of Alice Tumblin

Alice Tumblin

  • 4 Posts
  • 0 Reply Likes
The next problem......

I can not import new media through a get media from folder search into the converted catalog. It just says "import failed."

I try to import media from the same folder through the same mechanism in Organizer 11 and it works just fine. The folder in question is contains 550 jpg files, 21 of which were new and the remainder already in the catalog.

Please let me know if I need to post a "new" problem report regarding this.

Please let me know if you have another fix for this.

I am back working in Organizer 11 and not happy about it.