Element Organizer: Smart Tag language switched.

  • 1
  • Problem
  • Updated 6 years ago
  • (Edited)
I've had a variety of issues with Organizer but the latest one has me stumped. I opened it up today and found all the keyword tags I'd previously created are showing up in a randon font/language. It looks Slavic but what do I know I'm not a linguist. I just know it isn't English.

The menus and everything thing else display fine its just the keyword tags that are messed up.

Anyone else seen this or know of a fix. I've restarted several times and this seems to be a permanent change. There is no setting in Preferences that obviously fixes this. Attached is a screenshot of what I'm seeing.

I will say that generally I use Lightroom for pictures but since I started trying to use Premiere Elements for video clips I'm feeling forced to use Organizer as Lightroom doesn't really do video clips very well.

Photo of Ian Clements

Ian Clements

  • 1 Post
  • 0 Reply Likes
  • amused but not enjoying

Posted 6 years ago

  • 1
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 107 Reply Likes
That certainly is strange. Usually, strange behaviors like this are caused by corruption of the preferences. I'd suggest recreating those:

NOTE: Depending on your OS version and settings, some of these folders may not appear. Consult your OS documentation for instructions on how to reveal these.

1. Close Photoshop Elements and navigate to the preferences folder:
--Windows XP: C:\Documents and Settings\[User Name]\Application Data\Adobe\Elements Organizer\[Version]\Organizer
--Win Vista/7: C:\Users\[User Name]\App Data\Roaming\Adobe\Elements Organizer\[Version]\Organizer
--Mac: //Users/[User Name]/Library/Preferences/

2. Rename the preference file:
--Windows: psa.prf to psa.old
--Mac: "com.Adobe.Elements Organizer.[version].plist" to "com.Adobe.Elements Organizer.[version].old"

3. Reopen the Elements Organizer.