Photoshop Elements: Organizer will not print

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
Elements 9 organizer reports the following error whenever I try to use the print function on any file. "Elements 9 Organizer has stopped working...a problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available" the only option is to close the program. No solution is provided

If I open organizer and send the file to edit in photoshop elements the print function seems to work.

This is v 9.0.3 on a i7 core and W7. Printing used to work but it suddenly stopped.
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1668 Reply Likes
Sounds like it might be a driver issue. What printer and what driver version are you using?
Photo of Andy Royce

Andy Royce

  • 1 Post
  • 0 Reply Likes
Printer is HP 9670 that uses HP Deskjet 9800 print driver 0.3.7071.0. The print function worked several weeks prior to the current event and I am thinking prior to a recent Elements automated upgrade.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 107 Reply Likes
It's been a while since we've had any updates for Photoshop Elements. The most recent update, 9.0.3, was for the Editor, not the Organizer. The 9.0.2 update, which did modify the Organizer, came out in January.

You are probably running Windows 7, which is why you would be using the wrong driver (the 9670 would normally use the 9600 series drivers, but this printer doesn't work natively on Windows 7 and must use the 9800 drivers as a work around). Did you follow all of the instructions here?: http://h10025.www1.hp.com/ewfrf/wc/do...
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
I did follow all the instructions and got the printer to work when I bought this PC over a year ago. The printer works fine in all other applicaitons and like I said worked using the organizer up until recently. The fact that it work using the elements editor but not out of organizer is very strange.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Not too strange, the two programs use very different print modules. The one in Organizer is designed for versatility, printing multiple images (contact sheet, picture package). Printing from Editor is for quality, one image at a time but it is color managed and supports a higher DPI. So, if you are printing only one image at a time, I highly recommend avoiding the Organizer, it is always lower quality.
Photo of anchita dogra

anchita dogra, Employee

  • 34 Posts
  • 7 Reply Likes
Hi,
I am also using PSE 9.0.3 and an Epson Printer. Print works just fine via my Organizer. Could you try Slecting all files in Organizer and right click and do an 'Update Thumbnail'. Does this help ? Thanks.
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
Tried the Update Thumnail...no joy
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
I installed the driver according to the directions in the web page and I am able print to the driver (I don't have the printer, so no print, but it seems this should work for you). At what point do you get the error? As soon as you click File>Print? When you click the Print button inside the Print dialog box?

Something to try: Create a new catalog (File>Catalog: New), import the sample files that come with Elements (C:\Program Files\Adobe\Photoshop Elements 10\Sample Files), then try to print one of them.

If that works, try importing the same files into your normal catalog and test print one of them.
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
Creating the new catalog did not work...this did remind me that when the last automatic upgrade installed it actually failed and errored out and said something about contacting Adobe. Is there a log file that would reveal what this failure was all about? BTW this is v9.
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
No Joy...reinstalled software and reconnected the old catalog but still generating same error. Very strange.
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Going back to an earlier question:
At what point do you get the error? As soon as you click File>Print? When you click the Print button inside the Print dialog box?
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
Error pops up as soon as I press ctl P or if I open file menu and click on print
Photo of Brett N

Brett N, Official Rep

  • 2257 Posts
  • 108 Reply Likes
Do you have multiple printers installed on this machine? If so, could you try changing to a different printer as the system default? Especially if this is a network printer.
Photo of Andy Royce

Andy Royce

  • 8 Posts
  • 0 Reply Likes
Only one printer and it is connected via USB. I tried deleting the printer and reattach...no joy.