Elements 12.0 (Mac, Mavericks 10.9.1) won't import from iPhoto (9.5.1)

  • 2
  • Problem
  • Updated 4 years ago
Using the "Import from iPhoto" tool in Elements 12, it runs and runs but keeps stopping at 95% and giving me a fail message. I have rebuilt by library in iphoto to get rid of duplicates and any missing files, and still it stops at 95%. I split my library in half (from ~75,000 photos to 2 libraries of 38k), and still, import seems to be going well, all files are found but then import stops at 95%!! The error message says that 32,000 or so photos were imported, but this does not seem to be the case at all.
Photo of brent nedella

brent nedella

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 2
Photo of Sue Anderson

Sue Anderson

  • 1 Post
  • 0 Reply Likes
I have had this same problem. After crashing twice when trying to import my entire iPhoto library, I tried selecting 1 event to import. Organizer still said that it was importing 20,000 + items, even though there were probably only 24. After that, no matter how many events I tried to import, Organizer still said that I was importing 20,000. I've given up and haven't tried again in the last week or so.

One other thing, I upgraded to the Mountain Lion operating system after buying Elements 12 because Organizer required it to run. It wouldn't open with my Snow Leopard OS. So now I have Elements 12 and a new operating system, but I can't do what I want to do! I really wanted to use organizer because I haven't been completely happy with iPhoto.