Elements: PSE 11 Organiser bug (case 184432842)

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
As reported in case 184432842 which was closed by you while I was awaiting your response, I cannot load photos into Elements 11 Organiser from my C: drive. They all adopt a G: designation. Your team in India seem to have washed their hands of the problem by ignoring it. My only workaround is to transfer all original photos to an external HDD and transfer from there. It is infuriating that I spend a great deal of time with people in India who have replicated the problem by taking over my computer remaotely yet find themselves unable to either admit that there is a bug or advise how to change registry settings to get Elements to work properly. I would like a proper response to the case
Photo of Tony Lloyd

Tony Lloyd

  • 1 Post
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 115 Reply Likes
Tony, it appears that you are mirroring your C: drive to G:. They both have the same name, and are reported as having the same amount of available and used space. Essentially they are behaving as the same drive, so there is no difference between C: and G:.

You mention that the Google drive (G:) is only there to backup 4 directories (which we do see if we look at the contents of the drive), but as far as your OS is concerned, it is the same as C:. So your computer is telling the Organizer that is where these files are stored.

Even though the wrong drive letter is being reported, are you experiencing any adverse effects? It doesn't seem that the files are disconnected within the Organizer. If you click the Location link next to where the file path is displayed in the Information panel, do you get an error? Or does it open an Explorer Window to where the file is stored?
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 115 Reply Likes
Tony, it appears that you are mirroring your C: drive to G:. They both have the same name, and are reported as having the same amount of available and used space. Essentially they are behaving as the same drive, so there is no difference between C: and G:.

You mention that the Google drive (G:) is only there to backup 4 directories (which we do see if we look at the contents of the drive), but as far as your OS is concerned, it is the same as C:. So your computer is telling the Organizer that is where these files are stored.

Even though the wrong drive letter is being reported, are you experiencing any adverse effects? It doesn't seem that the files are disconnected within the Organizer. If you click the Location link next to where the file path is displayed in the Information panel, do you get an error? Or does it open an Explorer Window to where the file is stored?