Elements 10 Organizer changes photo Time

  • 2
  • Problem
  • Updated 6 years ago
I need to keep photos in the same order for viewing as JPEG CDs. Some DVD players sort and display slideshows by File number sequence, others by Date/Time sequence. So I try to ensure both types of data maintain the correct order.

However, I have encountered problems with Elements 10 Organizer, which repeatedly change photo Date/Time stamps:
a) Importing a photo into Organizer sets back a photo's time by one hour in Organiser!
b) Opening a photo file from Organizer, for Edit in the Editor, sets a photo's time back by one hour in Organizer, and also sets back the photo-file's EXIF time by one hour!

I carried out the following test:
Created JPEG file at 12:36.
In Preview>Tools>Inspector, EXIF time is 12:36 (correct).
Opened Organizer, and imported the photo.
In Organizer, time appears set back to 11:36.
In Preview, EXIF time remains at 12:36
In Organizer, selected photo, then >Fix >Full Edit.
In Organiser, time sets back further to 10:36 and in Preview, file's EXIF time sets back to 11:36, before Editor opens.

It is very time wasting to have to manually re-adjust photo Times after every import and every edit session. When is this bug likely to be fixed?
Many thanks,
Peter

UPDATE:
I have now found that Organiser only resets Time in certain batches of photos.
Examing File Info in PSE Editor, Advanced, EXIF Properties, it appears that Organiser sets Time back where Exif Date Time ends with +01:00, but NOT where it ends with Z.
Both batches of files have Meta Data Date ending with +01:00.

UPDATE 2:
Changing the time stamp in Organiser also replaces the image file on my Mac.
The new file also loses its PSE custom image borderless-thumbnail.
Mac's Preview creates a new bordered-thumbnail.
If I add a new photo to a folder, then import the folder into the organiser, Organiser should only import the new file, and reject the other files as they are already in the Organiser Catalogue.
However, Organiser re-imports every image file that has had a time change by Organiser! It appears to consider image files without borderless custom thumbnails
to no longer be included in the catalogue.
Photo of PETER BOXELL

PETER BOXELL

  • 13 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 years ago

  • 2
Photo of Christer Widlund

Christer Widlund

  • 1 Post
  • 0 Reply Likes
We have the same problem with Elements on two iMac, OS X, 10.7.4