Elements Organizer 14 Crashes Every Time I Try to Import

  • 2
  • Problem
  • Updated 3 years ago
I have a new, cleanly installed and fully patched Win10 that I have installed Photoshop and Premiere Elements 14 on (also installed 12).  I have fully updated Elements.  I am an advanced user and monitor resource utilization and my event log and have checked my disks.  There are NO issues on my PC other than this...Elements Organizer fails every single time I try to import.  I've looked around and this is a very common problem.  Here's my event log file:

Log Name:      ApplicationSource:        Application Error
Date:          2/10/2016 4:24:01 AM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Annette10E
Description:
Faulting application name: PhotoshopElementsOrganizer.exe, version: 14.0.0.0, time stamp: 0x566554ab
Faulting module name: mc_mfimport.dll, version: 9.8.11.5916, time stamp: 0x534fe0c0
Exception code: 0xc0000005
Fault offset: 0x000000000001f083
Faulting process id: 0x18cc
Faulting application start time: 0x01d163d773e7b51d
Faulting application path: C:\Program Files\Adobe\Elements 14 Organizer\PhotoshopElementsOrganizer.exe
Faulting module path: C:\Program Files\Adobe\Elements 14 Organizer\dynamiclinkmediaserver\mc_mfimport.dll
Report Id: 7cfe3be3-fd76-4fd9-a6d5-a8fad2a85d6c
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">;
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-02-10T09:24:01.309724800Z" />
    <EventRecordID>6699</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Annette10E</Computer>
    <Security />
  </System>
  <EventData>
    <Data>PhotoshopElementsOrganizer.exe</Data>
    <Data>14.0.0.0</Data>
    <Data>566554ab</Data>
    <Data>mc_mfimport.dll</Data>
    <Data>9.8.11.5916</Data>
    <Data>534fe0c0</Data>
    <Data>c0000005</Data>
    <Data>000000000001f083</Data>
    <Data>18cc</Data>
    <Data>01d163d773e7b51d</Data>
    <Data>C:\Program Files\Adobe\Elements 14 Organizer\PhotoshopElementsOrganizer.exe</Data>
    <Data>C:\Program Files\Adobe\Elements 14 Organizer\dynamiclinkmediaserver\mc_mfimport.dll</Data>
    <Data>7cfe3be3-fd76-4fd9-a6d5-a8fad2a85d6c</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

Here is another event log or a transient problem (the app keeps dropping away with just the dialogue open, becoming non-responsive):

Log Name:      ApplicationSource:        Windows Error Reporting
Date:          2/10/2016 7:21:55 PM
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Annette10E
Description:
Fault bucket , type 0
Event Name: AppHangTransient
Response: Not available
Cab Id: 0

Problem signature:
P1: PhotoshopElementsOrganizer.exe
P2: 14.0.0.0
P3: 566554ab
P4: unknown
P5: unknown
P6: unknown
P7: unknown
P8: 
P9: 
P10: 

Attached files:

These files may be available here:


Analysis symbol: 
Rechecking for solution: 0
Report Id: 73451adb-d055-11e5-a3a3-001c23594dba
Report Status: 2049
Hashed bucket: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">;
  <System>
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-02-11T00:21:55.760930900Z" />
    <EventRecordID>6792</EventRecordID>
    <Channel>Application</Channel>
    <Computer>Annette10E</Computer>
    <Security />
  </System>
  <EventData>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>AppHangTransient</Data>
    <Data>Not available</Data>
    <Data>0</Data>
    <Data>PhotoshopElementsOrganizer.exe</Data>
    <Data>14.0.0.0</Data>
    <Data>566554ab</Data>
    <Data>unknown</Data>
    <Data>unknown</Data>
    <Data>unknown</Data>
    <Data>unknown</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>73451adb-d055-11e5-a3a3-001c23594dba</Data>
    <Data>2049</Data>
    <Data>
    </Data>
  </EventData>
</Event>
Photo of Annette Lerner

Annette Lerner

  • 1 Post
  • 0 Reply Likes

Posted 3 years ago

  • 2
Photo of fons simons

fons simons

  • 9 Posts
  • 0 Reply Likes
other images from a new camera? 
Photo of Anwesha

Anwesha, Employee

  • 72 Posts
  • 8 Reply Likes
Hi,

Do you also have video files in the media set you are trying to import?
Can you please try importing only images and see if EO still crashes?

Thanks,
Anwesha
Photo of emilast

emilast

  • 1 Post
  • 0 Reply Likes
I have very similar problems with version 14. I'm also on Windows 10 and the computer have no other problems that I'm aware of. Crashes every time I import picture from a memory card. The import is successful though and the images are indeed in the catalog when restarting the Organizer.

Any ideas about what can be done about this?

/Emil