Elements 2019: Show/Hide Layers Incredibly Slow

  • 1
  • Problem
  • Updated 9 months ago
  • (Edited)
This is my first post on the Adobe forum.  I just installed Photoshop Elements 2019 in order to manipulate some raw (.NEF) images I captured from my DSLR (Nikon D3200).  The photos were of the lunar eclipse, so each one needed to be cropped significantly prior to use in each layer.  Each moon photo was placed in a separate layer and moved/resized to make the sizes/orientation consistent between layers.  The idea being to selectively show/hide layers to see the different phases of the moon (in the editor not the final image - where I could choose a particular shot).    Here is a link to the PSD and the screenshot below shows this in the application.

If you wish to reproduce the performance issue, just selectively show/hide layers and you will see it takes ~2-3 seconds to refresh the display.  The file size is not crazy (~4Mb) so I don't understand the reason for the slowdown.  My system is a 4.2Ghz (overclocked to 4.8Ghz) Windows 10 i7 7700K machine with 32G ram.  Note: I am on the insider ring (not sure if that is a factor), but so far this build seems stable.  Unfortunately I do not have the older version of Photoshop (the last one I purchased was in 2016) to see if this is a regression.

Thanks in advance, are others seeing this lousy performance?

John

EDIT:  I figured out the problem, it appears to be a bug in Photoshop Elements.  The issue had to do with the Crop tool being selected.  Once I selected another tool in the left side, it was snappy as usual.  Adobe: is this a known problem or is the software attempting do so some special manipulation in the background for all layers while the crop tool is selected?


 
Photo of John Coffey

John Coffey

  • 1 Post
  • 0 Reply Likes

Posted 9 months ago

  • 1
Photo of Steve

Steve

  • 69 Posts
  • 18 Reply Likes
Nice image(s)! Your machine should be very fast with that CPU and RAM. 

The crop tool does processing in the background. It calculates and suggests several possible crops. If you click tool guides, you should see those suggestions. This may be causing the delays you were seeing. Try changing the preferences and then try the crop / select layer. Please post if this in fact causes the delay. I would like to know. 

To turn off Crop Pre-Selection go to Preferences / General. See the screenshot below:



Steve G