Elements 2019 Organizer does not recognize images that it has already imported on import

  • 1
  • Problem
  • Updated 12 months ago
Hi,
I'm a new user of Adobe Photoshop Elements 2019 Organizer. I just imported images from a card yesterday fine. Then I took some more images today and went to import them, but the import function does not seem to know that it has already imported yesterday's images and wants to reimport them all as new images. The duplicates button is grayed out (doesn't seem to know they are there). I just tried to import todays images again and they look completely new to the import screen also, i.e. I've done nothing to the images except import them-- they still don't seem to be recognized.  Help! Is this the normal way that Elements works? My old Lightroom5 could tell duplicates and didn't import them. Thanks.
Photo of Lisa

Lisa

  • 4 Posts
  • 0 Reply Likes

Posted 12 months ago

  • 1
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1312 Posts
  • 276 Reply Likes
Let's start with checking the preferences of your organizer.
Menu Edit >> preferences >> Camera or card reader.
Did you check the option to 'copy new files only' ?


Photo of Lisa

Lisa

  • 4 Posts
  • 0 Reply Likes
Thank you so much for your reply. I don't seem to have that option under preferences. I'm using a Mac, and the newest version of Adobe Elements 2019 Organizer.  When I select Preferences >> Camera or Card Reader, I only see three check box options: automatically fix red eyes, automatically suggest photo stacks, and automatically stack raw and jpeg.  There's also a place to designate where to save the files. I don't see an option to select 'copy new files only'.  Is there another preference menu I should be looking for? Thank you again, I'm not finding anything else online that can help me with this problem so I really appreciate it.  [Edit: Reading through the Adobe help page, it looks like that option might only be available on Windows.]. 
(Edited)
Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1312 Posts
  • 276 Reply Likes
For some unknown reason, my PSE2019 in Windows 10 recently stopped filtering only not already imported files when importing from 'camera or card reader'. The filter still works when importing from files and folders.
In that situation, I use the downloader in 'advanced' dialog mode. The thumbnails show the files in chronological sort  order, newest first on top. I just select the new files from that dialog. In Windows I click on the newest thumbnail (not on the checkbox), then I scroll down to the latest file not already imported, Shift click on its thumbail. That shows the batch with highlighted thumbnails. Then I click on any of the checkboxes of the selected files. That's all, only those will be imported.
I hope this workaround can help you until the root of the issue is found.
Photo of Lisa

Lisa

  • 4 Posts
  • 0 Reply Likes
Thank you very much, I really appreciate your reply. Thanks for the workaround and yes I have tried this workaround too and it works. However since this is new software for me and I'm trying to find a good piece of software to finally organize all my old photos from iphoto, photos etc. I'm not sure if it will end up being the right software, if this is a permanent issue (seems like was for some folks in older versions on mac of the software?). In Lightroom 5 the dupes are always detected. But maybe there will be a fix for Elements Mac version. In a separate question, is there any way to ask Adobe support about this specifically? The website does not seem to have a way for me to contact them (I have a standalone paid version of Adobe Premiere and Photoshop Elements). I'm wondering if I can only contact support if I'm on the more subscription based plan.  Thank you SO much again for your reply about the import.