elements 2018 won't open task manager says "not responding"

  • 1
  • Problem
  • Updated 6 months ago
I have Adobe Premiere Elements 2018. I've had it for about 6 weeks. Yesterday it worked perfectly. Today when I try to open the program I get to the start page where I can choose photo editor, organizer or video editor.

The photo editor opens like usual, no problem there. The video editor gets as far as "initializing application" and nothing else happens. Task manager says it is "not responding". Help! I have a project I am in the middle of and really don't want to lose. I really need a way to get back into elements without re-installing (so I don't lose my project).

The organizer option won't open either...

Thank you!!!
Photo of rachael

rachael

  • 1 Post
  • 0 Reply Likes
  • frustrated and worried

Posted 6 months ago

  • 1
Photo of Andy Video

Andy Video

  • 8 Posts
  • 2 Reply Likes
Hi Rachel,

Your project is held in a ".prel" file. This file will not be affected by a re-installation of PrE, nor even the installation of another version of PrE (although earlier versions of PrE may object to .prel files created by a later version).

Before doing anything else you could try launching PrE from the .prel file itself (in Windows just double click on the .prel file), instead of running the app and then selecting which project you want to work on.

You could also try a "reboot" of your system (on Windows ensure you use "Restart" rather than Shutdown followed by a startup, as the latter does not give a clean start when using Windows default settings). 

If you don't know where the .prel file is then try looking in the default location. On windows this is:
<device>:\Users\<username>\Documents\Adobe\Premiere Elements\16.0
where <device> is normally the "C" drive, <username> is your log-in account name, and the 16.0 is what the software uses for "Elements 2018".

If you have been working on a project for some time then I would recommend you back up the .prel file from time to time (just copy the .prel file to another disk if you don't have any other means of backing up).

If a reboot does not clear the problem then try reinstalling PrE (you probably can to do this without having to reinstall PSE 2018 too).
Photo of Ross West

Ross West

  • 1 Post
  • 0 Reply Likes
This is the most common error message that every windows user have facing. This happens when upgrading the windows from old version to new version. I have faced this same issue when I upgrading my windows that "task manager not responding". I troubleshooting some basic steps like 1) Reboot my system.  2) Install Available Updates. 3) Sign out from current user. 4) Uninstall third party antivirus or apps. 5) Run system file scanner. 6) Repair windows image. 6) Run CCleaner. 7) Re-register the taskbar using Windows Powershell. 

If the above steps are not working, then you should do fresh clean windows installation.