Elements 2018 runs painfully slow on iMac after update to Mojave 10.14

  • 6
  • Problem
  • Updated 4 days ago
Elements runs extremely slow on iMac since updating from High Sierra 10.13 to Mojave 10.14. Organiser has become virtually unusable taking about 3 minutes to open and any activity such as deleting files from the catalogue presents the spinning beach ball for about 70 seconds until the task completes.
Photo of David Gwinnett

David Gwinnett

  • 1 Post
  • 0 Reply Likes

Posted 4 weeks ago

  • 6
Photo of Michelle Kantrow-Vázquez

Michelle Kantrow-Vázquez

  • 1 Post
  • 0 Reply Likes
I have the same problem! Any insights???

Photo of Marcia Hodges

Marcia Hodges

  • 1 Post
  • 0 Reply Likes
same problem

Photo of Mark Bassett

Mark Bassett

  • 1 Post
  • 0 Reply Likes
Same for me too. Unusable. Very annoying.

Photo of Admin PatronPoint

Admin PatronPoint

  • 1 Post
  • 0 Reply Likes
Same problem...almost unusable.
Photo of 三佳 加藤

三佳 加藤

  • 2 Posts
  • 1 Reply Like
I have the same problems sometimes, though mine is still usable about half the time (generally, right after a restart). Even then, any tool changes into a rotating pattern of dots so that it is impossible to accurately move.
Photo of 三佳 加藤

三佳 加藤

  • 2 Posts
  • 1 Reply Like
I'm back with at least a partial solution. You have to give Elements permission to control your computer. It's under System Preferences - Security & Privacy - Privacy. I found this article: https://helpx.adobe.com/photoshop/kb/photoshop-and-macosmojave.html
It's about Photoshop, but it helped me.