Elements 14: Starts to open program then shuts down

  • 3
  • Problem
  • Updated 2 years ago
  • (Edited)
I installed Elements 14 four months ago.  Has been working fine but for last few weeks when I upload photos it starts to open the organizer and then shuts down.  If I try to open the program from the desktop it won't open.  Not sure what to do.  Should I uninstall and reinstall it......
Photo of leamtomato

leamtomato

  • 1 Post
  • 0 Reply Likes
  • frustrated!

Posted 2 years ago

  • 3
Photo of Norm Samuelson

Norm Samuelson

  • 2 Posts
  • 0 Reply Likes
I am having the same problem.  Have you found a solution?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 768 Reply Likes
What OS version?
What error do you see?
Photo of Norm Samuelson

Norm Samuelson

  • 2 Posts
  • 0 Reply Likes
I am running Windows 10.  I get no error message.  When I first click on it, it opens the program, it starts with the splash screen, then an empty window, then placeholders for pictures show up (but no pictures), then it disappears.  No error message, it just disappears.  If I try again, NOTHING comes up.  I have to reboot to get it to open.

If I bring up the editor, then switch to the other, I was able to get it to stay on the screen.  I tried importing pictures from a USB drive.  It read thru the drive, but the pictures never appeared, and it was stuck in a very strange state.  I could not get any response, other than minimizing it when I clicked in the lower right corner of the screen, and reappear when I clicked on the icon at the bottom, but that was ALL it would do.

I have been using Photoshop Elements for many years, since version 5 (I think).  It was working when I first ran version 14, but recently it has been getting hard to import pictures, and now it is virtually useless.

I reinstalled Elements 14, but that did not help.

I have thousands of pictures.  All imported by Photoshop Elements.