Elements 14: Shake Reduction always fails "no more virtual tiles can be allocated"

  • 3
  • Problem
  • Updated 3 years ago
  • (Edited)
In Photoshop Elements 14 - trying the new "shake reduction" always errors "no more virtual tiles can be allocated"

Before anyone tells me to improve the RAM settings - I am using the 64-bit install, on Win 10 64-bit, and I have 32 GB Ram, and the scratch disk has 126GB free.

I set the preference > Performance to the recommended 20623MB usage.

I have as an exercise loaded several GB of photos into Elements, and they load OK.

The problem (so far) is confined to the Shake Reduction feature.

I've even cropped in the photo to a small area - but every attempt at "Auto Shake Reduction" or "Shake Reduction..." gives the same error.
Photo of Neil Taylor

Neil Taylor

  • 5 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1896 Reply Likes
Someone from the Elements team will need to ultimately help, but one thought is to make sure your video card driver is up to date. Determine what video card you have and go *directly to the manufacturers website (nVidia or ATI/AMD)* and download the latest driver: http://blogs.adobe.com/crawlspace/201...

Just doing Windows Update won't give you the latest and greatest drivers. You must go directly to your card manufacturers website to check for driver updates.
Photo of Neil Taylor

Neil Taylor

  • 5 Posts
  • 0 Reply Likes
Thanks - nice idea ...
but
a) the driver is nVidia's latest (it's a new Win10 setup, with new hardware, new drivers,...) (and the video card has 4GB ram, too).
b) while the video driver might cause problems generally, this is an exception for one specific command, and always, instantly falis, before it even mounts the "what do you want to do" dialog.

As a software developer myself, it smacks of someone using a 32-bit value, and finding there's "too much memory".

When I get some time I should try out the 32-bit version and see if it's the same.
Photo of Neil Taylor

Neil Taylor

  • 5 Posts
  • 0 Reply Likes
** Ah! 32-bit Elements is not supported on Win-64, so I can't make the obvious comparison **

I should be very explicit here:
When either of the "Shake Reduction" commands is invoked from the menu,immediately Elements mounts for "no more virtual tiles" error.

No pause.

No mounting the interactive dialog to talk about where to base the reduction, and how much.

Just fails.

So it's most likely that a pre-calculation "do I have the resources for this effort" is broken.

I also point out that all the other commands I have tried work well, even when the program is deliberately congested with other images.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1896 Reply Likes
OK. One of the engineers from Elements engineers will have to pipe in.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 818 Reply Likes
A 32 bit application would still run on a 64 bit OS. It's only a 64 bit app that cannot run on a 32 bit OS.
Photo of Neil Taylor

Neil Taylor

  • 5 Posts
  • 0 Reply Likes
true, and I know that - but it's not the problem.

Photoshop Elements 14 is supplied as 2 .EXE installers: PhotoshopElements_14_LS28_win64.exe targeted solely at 64-bit OS, PhotoshopElements_14_LS28_win32.exe solely at 32-bit OS.

If you fire up PhotoshopElements_14_LS28_win32.exe on Win-64, it runs (of course), but once it unzips the temp files, it checks the kind of OS, and refuses to complete the installation. Adobe have chosen to restrict installers to match the size of the OS.
Photo of Akshaya Saxena

Akshaya Saxena, Employee

  • 97 Posts
  • 4 Reply Likes
Neil,

Looks like there could be some permission error due to which Elements is not able to create virtual memory files.

Are other filters like liquify working fine?

Thanks,
Akshaya
Photo of Neil Taylor

Neil Taylor

  • 5 Posts
  • 0 Reply Likes
Thanks - I found the problem.

Ever since Windows Vista (2007) Microsoft have made access to C:\ a privileged operation. They also make writing to %Program Files% privileged.

However, now, in 2015, 8 years on, the newest Elements still only accepts a drive letter (root) as indicating scratch spaces. You cannot specify a path in Elements Preferences...
Since it also defaults to C: it tries to write to C:\ and fails.

The message "no more virtual tiles can be allocated" is ... well, clear as mud, actually. It tells the user nothing useful.

Fortunately I have more than one drive, so eliminating C: and using a different drive makes this and any similar command work fine.

Suggestions:
1) on a 64-bit system with 32GB ram, using disk space for anything is pretty pointless. There is more than enough real memory.

2) assigning a path to the scratch area, or even just using the TEMP environment variable, would be better than using a drive root.

3) improving error messages would help, too...