Elements 14: Runs very slow on my system

  • 15
  • Problem
  • Updated 9 months ago
  • (Edited)
I have used Photohop Elements 11 for a few years and love it. I recently upgraded to Elements 14 and when I try to use it it is like trying to walk though molasses. It makes it very hard to use because the mouse pointer has a bad lag time so I can not see what I am doing in real time. I still have my Elements 11 and it works fine. Help!
Photo of Linn Ann Guss

Linn Ann Guss

  • 1 Post
  • 0 Reply Likes

Posted 2 years ago

  • 15
Photo of diane weist

diane weist

  • 4 Posts
  • 2 Reply Likes
I did the same - 11 to 14, brand new IMac, adequate memory. If there;s not an update that speeds it up, I'm return to amazon for a refund and finding another editing program.
Photo of Linda Frost

Linda Frost

  • 1 Post
  • 0 Reply Likes
I did exactly the same.  What a disappointment.  I'm a long time Elements user.
Photo of Theresa Holl

Theresa Holl

  • 1 Post
  • 0 Reply Likes
I'm drowning in quicksand. Running 14 on Surface pro 3 i5 with 8gb RAM. I should be flying. Pretty disappointed and hope Adobe gets me a no cost fix in a timely manner. looks like I'm not the only one.

Takes several minutes to save anything. Zooming in and out stutters a lot along with many basic functions. Come on Adobe. Seriously.
Photo of Flo Hendry

Flo Hendry

  • 3 Posts
  • 1 Reply Like
Now that I have close to 3K photos on my Windows 7 Pro,, 16 gb RAM I7 processor, PSE 14 Organizer is so slow, sme problems that Theresa Holl mentioned.  Editor is ok... Maybe there is a Facebook page for Adobe and public postings to the problems of PSE14 could be made known. I would use PSE12 but it does not support the new Olympus ORF RAW files.... An update is long overdue from Adobe. Even a courtesy response in this forum I guess is asking too much....
Photo of Genevieve Stubbs

Genevieve Stubbs

  • 1 Post
  • 0 Reply Likes
Same problem! Brand new iMac, fresh install brand new PSE 14, slow performance. The spinning beach ball appears so often, it's too frustrating to do anything. I have 16 gigs of RAM and a 2TB hard drive. I maxed (actually over maxed) the amount of memory PS is allowed to use in the preferences. Now its 80% and the stupid beach ball still shows up every 10 seconds or so. Is there an answer to this????
Photo of Flo Hendry

Flo Hendry

  • 10 Posts
  • 3 Reply Likes
Yup, SLOW on Win 10 machine. Not happy with organizer! Does Adobe even care?
Photo of Flo Hendry

Flo Hendry

  • 3 Posts
  • 1 Reply Like
I gave up running it on Win 10 and put it on my Win7 Pro and it runs so much faster! 
Photo of Flo Hendry

Flo Hendry

  • 3 Posts
  • 1 Reply Like
Now that I have close to 3K images it is running SLOW .... forever for the thumbnails in RAW format (Olympus ORF) to come into 'focus' even when I just import 7 images.  ADOBE WHAT ARE YOU DOING ABOUT THIS??   BTW they do have a Facebook page.... I don't have a  Twitter account...  Hopefully people will start posting on sites so that people who do not have PSE14 are forewarned about the organizer.
https://www.facebook.com/PhotoshopElements/?fref=ts
Photo of Roger Whiting

Roger Whiting

  • 2 Posts
  • 0 Reply Likes
Have used Photo Elements for a number of years...Photo Elements 14 is simply the slowest program of any kind that I have ever used...crashes repeatedly...I thought that the Blue Screen of Death was bad in the day...But this is horrible.  And to think that Adobe ignores this issue...Does anyone out there know of a program that organizes, dates, uses facial recognition...oh were is Picassa when you need it?
Photo of David Czaya

David Czaya

  • 1 Post
  • 0 Reply Likes
At first, Elements 14 was acceptably slow. Now, it has slowed down to a virtual crawl. I just uninstalled it including all preferences, then re-installed it completely. No change. What has happened? Is there a fix yet? I can't even stand to use this now.

Edit: I have tried all of the suggestions I found for improving performance including having 16MB ram, using a dedicated scratch disk (675GB free), performance setting at 75% use of available ram, turned off face recognition in organizer, etc. And yep, running Windows 10. Been a PE user since like V2 or so. Sad.

Help us, Adobe.
(Edited)