Elements 14: Map not displayed

  • 5
  • Problem
  • Updated 5 days ago
  • (Edited)
In the Organiser, select a folder, select Places - no map is displayed, the map area is completely black

Selecting either Pinned or Unpinned makes no difference.

Placing a photograph in the map space does not appear to work.

Adobe updates and Windows 10 updates both current.

I raised a very similar fault a year ago to the day. It was 3 months before it was fixed. Is this the same problem? Will it take 3 months to fix?
Photo of Michael Prince

Michael Prince

  • 1 Post
  • 0 Reply Likes
  • Annoyed and Frustrated that an apparently fixed bug has reappered

Posted 1 month ago

  • 5
Photo of Ian Buchanan

Ian Buchanan

  • 1 Post
  • 0 Reply Likes
I too have the same problem. Map function worked fully up to 14 August 18. I’m not aware of any updates being applied to Elements 14 or Google maps that would cause the disappearance of the function. Extremely frustrating as I’m partway through a major exercise of consolidating an extensive collection of old print/slide photos and digital image files in a single library with geolocation etc. I started this with Picasa, switching to PE14 when mapping stopped in Picasa. I’m reluctant to buy Elements 2018 as a quick fix.
Photo of Stewart

Stewart

  • 1 Post
  • 0 Reply Likes
This is also my case with my large collection of old photos and slides, which I've been scanning. The places function, never my favorite since upgrading to PSE14, stopped working in August. I just wish Adobe would modify the Places functions to permit manual entry, as in earlier versions. Tying Places to a map program took away the ability for categorizing groups of places, such as zoos, National Parks, Castles, etc., which I used a lot. Migration of these categories to Other resulted in a lot of extra work. Now I'm dead in the water, if I have a new Place.

Photo of Michel BRETECHER

Michel BRETECHER, Champion

  • 1085 Posts
  • 227 Reply Likes
Photo of Daniel-T

Daniel-T

  • 1 Post
  • 1 Reply Like
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
https://helpx.adobe.com/elements-organizer/kb/maps-not-loading.html

Map does not load | Elements Organizer 11, 12, 13, and 14

When you navigate to the Places view in Elements Organizer, the map does not load. This issue was reported in Elements Organizer 11, 12, 13, and 14.
The error in the Places view is a result of Google Maps changing how map data is delivered to applications like Photoshop Elements.