Elements 13: Crashing on launch on Windows 7

  • 3
  • Problem
  • Updated 3 years ago
  • (Edited)
I recently bought Photoshop Elements 13 in the form of a CD. I had previously run Elements 6 and am used to using the software. I downloaded the programme and it worked well to start with. On the following day, I downloaded an update and the programme continued to perform well. However, within an hour, the editing function stopped, although the organising side still worked. By the following day, the programme had stopped altogether. Since then, I have tried uninstalling and re-installing without success. I am running Windows 7 with a Firefox browser. Please advise.
Linda Haywood
Photo of Linda Haywood

Linda Haywood

  • 6 Posts
  • 0 Reply Likes

Posted 3 years ago

  • 3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
What do you mean by "stopped working"? What exactly are you seeing?
Photo of Linda Haywood

Linda Haywood

  • 6 Posts
  • 0 Reply Likes
I'm not seeing anything - Elements doesn't open at all when I click on the icon on the desktop. Instead, I get a message saying "A problem caused the programme to stop working correctly. Windows will close the programme and notify you if a solution is available."
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
OK, so you are seeing a crash on launch.

Check the Windows System Event Viewer or Reliability Reports for more details on the crash. We need to know the name of the faulting module to narrow down the cause.
Photo of Linda Haywood

Linda Haywood

  • 6 Posts
  • 0 Reply Likes
Hello Chris,
I've managed to find the Error messages in Event Viewer. I shall insert them below:

“The description for Event ID 1903 from source HHCTRL cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.”

Log Name: Application
Source: VSS
Date: 28/03/2015 19:23:44
Event ID: 8224
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: Linda-PC
Description:
The VSS service is shutting down due to idle timeout.
Event Xml:

8224
4
0
0x80000000000000

112856
Application
Linda-PC

2D20436F64653A2020434F525356434330303030303737332D2043616C6C3A2020434F525356434330303030303735352D205049443A202030303030313435362D205449443A202030303030363031322D20434D443A2020433A5C57696E646F77735C73797374656D33325C76737376632E6578652020202D20557365723A204E616D653A204E5420415554484F524954595C53595354454D2C205349443A532D312D352D313820
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
That has nothing to do with Elements. You need to find the crash report for Elements.
Photo of Linda Haywood

Linda Haywood

  • 6 Posts
  • 0 Reply Likes
Sorry about that - this is a real learning curve for me! I hope the following is what you require:

Faulting application name: PhotoshopElementsEditor.exe, version: 13.0.0.0, time stamp: 0x54024871
Faulting module name: PhotoshopElementsEditor.exe, version: 13.0.0.0, time stamp: 0x54024871
Exception code: 0xc0000005
Fault offset: 0x0000000000001e96
Faulting process id: 0x6e8
Faulting application start time: 0x01d0654cfdef13b3
Faulting application path: C:\Program Files\Adobe\Photoshop Elements 13\PhotoshopElementsEditor.exe
Faulting module path: C:\Program Files\Adobe\Photoshop Elements 13\PhotoshopElementsEditor.exe
Report Id: 40d0a12d-d140-11e4-bbb7-94de80dd70c9
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Ok, the Elements team will have to investigate this one.
Photo of Linda Haywood

Linda Haywood

  • 6 Posts
  • 0 Reply Likes
Please - how long will this take to investigate? I bought this software on 14 March 2015 and, so far, have had just 1 day's use of it. I now have a limited time in which to return it to the dealer in order to receive my money back.
Photo of Linda Haywood

Linda Haywood

  • 6 Posts
  • 0 Reply Likes
Chris - How long will this take to investigate? I am getting very frustrated by the lack of help from Adobe.
Photo of LYNNE STOWE

LYNNE STOWE

  • 1 Post
  • 0 Reply Likes
I'm having a similar problem with PSE13 Editor. When I go to launch Editor it tells me I need Windows 7, which I already have. I have tried reinstalling it several times to no avail. Now the Organizer does not work. I have had other forums trying to help me but so far nothing is working. Can you help with this
Photo of Elizabeth Millikin

Elizabeth Millikin

  • 1 Post
  • 0 Reply Likes
I also have this problem with windows 7 and Elements 12. I open the task manager and it says that elements is not responding, so i close it down. Maybe I have to many photo's in my catalogs? It used to work, could it be a ram problem? I got Lightroom installed also recently and I try to open and edit in Elements and many times it will not open or lock up shortly after opening.
Photo of Robert Sabaj

Robert Sabaj

  • 1 Post
  • 0 Reply Likes
We are trying Elements Premiere 13 after using 9 for years and 9 gave us problems that I could fix, but 13 continually destroys the consumer ir devices. Have removed 13 and finally after hours of work got my machine working again( I had to restore all the drivers) I am returning 13 and will try to find another editor. Adobe has been useless in helping fix the problems.
Photo of Barb Condit

Barb Condit

  • 2 Posts
  • 0 Reply Likes
frustrated
edit delete
Barb Condit 18 hours ago
I am using Windows 7, Vista, and PE8. I just finished editing 184 of The Charleston Emanuel 9 photos. I also had about 1,000 photos that became unconnected somehow??? I could not reconnect them with the SIM card as that option is not available in the reconnect option. I ended up having to download almost 3,ooo pics from my SIM card to an external hard drive hoping to reconnect photos in My Organizer with my external hard drive.

The Organizer will not open. Please help!!! I wrote Adobe "help" folks and another help site in their company but have not received an answer. The Organizer appears, says initializing, then 5 seconds later the site disappears. I am praying there is a solution that will not require me reinstalling as I will lose not only the Emanuel 9 but all the other edited photos that disconnected.

Thank you for any steps you can provide,
Barb