Elements 12: Software says not licensed after I previously licensed

  • 1
  • Problem
  • Updated 4 years ago
Tonight at 2 AM EST I started up my copy of Elements 12. I have had it for more than a few months - abt 45 days prior to 13 being released.

When I started it, I was told it was not licensed. When I logged into my account, the product and s# were not listed.

So wonderful support person on Chat was useless at tellling my what happened - only asked foolish questions. What the heck happened and why did it happen? What if I was on the road and I didn't have my software package with me? What would I have done then? Is there anyone who can make any sense out of this and tell me what the heck happened? This having to stay logged in is absolute idiocy.

Note: This conversation was created from a reply on: How to complain to Adobe?.
Photo of Nathan Alterman

Nathan Alterman

  • 3 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1894 Reply Likes
Hi Nathan, I see your Elements 12 was registered under your Adobe ID back in July of 2014. Are you not able to see this on your end?

In terms of your software becoming unlicensed, this can be cause by a few things, either a system/registry cleaner or utility - and in some cases where your system's clock is reset to a prior date (which can happen in the rare case that your battery is completely drained and your motherboard clock batter is also dead)
Photo of Nathan Alterman

Nathan Alterman

  • 3 Posts
  • 0 Reply Likes
Hi Jeffrey: When I logged into my account to see what was wrong, there was no record of any Adobe software listed. I have been using elements since 2 or 3.
As far as teh battery drain or clock change, neither has happened. I am on a monster POS.
I have used a registry cleaner and have been doing so for years. This is the first time any such occurrence has happened if that is the problem.

But why can't I see the registration in my Adobe account?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14551 Posts
  • 1894 Reply Likes
Try going here: https://www.adobe.com/account/my-prod...

I got to this page by signing in on Adobe.com, then clicking [Manage Account] in my profile section on the left of the screen, then [View All] and then "View other products associated with your Adobe ID" in the righthand column.

Did your registry cleaner do a recent update?