Photoshop: 14.2 Custom Shapes Tool reports program error

  • 2
  • Problem
  • Updated 1 year ago
  • (Edited)
following updating Photoshop CC from 14.1 to 14.2, custom shape tool displays an error message saying tool can't be used due to a program error (no error # specified). Issue still exists even after tossing the prefs file and running a complete AppleJack process on restart (repair disks, repair preferences, clean cache (both system & users), repair permissions, trash the virtual memory cache). Holding down shift on PSCC start-up had no effect on the problem. On working on an iMac using OS 10.6.8.
Photo of Leslie Javorek

Leslie Javorek

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 769 Reply Likes
Check the last several lines in the file PSErrorLog.txt in your Photoshop preferences folder, and post them here.
Photo of Leslie Javorek

Leslie Javorek

  • 3 Posts
  • 0 Reply Likes
2014:01:20 18:58:02 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20131211.r.515/photoshop/main/photoshop/xcode/../sources/USheet.cpp : 459 : REQUIRE failed
2014:01:20 21:07:50 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20131211.r.515/photoshop/main/photoshop/xcode/../sources/USheet.cpp : 459 : REQUIRE failed
2014:01:20 21:09:26 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20131211.r.515/photoshop/main/photoshop/xcode/../sources/USheet.cpp : 459 : REQUIRE failed
2014:01:20 22:51:02 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20131211.r.515/photoshop/main/photoshop/xcode/../sources/USheet.cpp : 459 : REQUIRE failed
2014:01:20 22:51:14 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20131211.r.515/photoshop/main/photoshop/xcode/../sources/USheet.cpp : 459 : REQUIRE failed
Photo of Leslie Javorek

Leslie Javorek

  • 3 Posts
  • 0 Reply Likes
Still having the same problem - unable to use the custom shape tool. Any clues as to why and/or how to fix it based on the excerpt from the PSErrorLog that I posted last week?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
All the error log tells me is that something tried to access a layer that does not exist. Unfortunately it doesn't tell me much more.
And I'm not sure why you are seeing this and other users are not.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1671 Reply Likes
This issue should be fixed in the 14.2.1 update: http://blogs.adobe.com/crawlspace/?p=...
Photo of Joe Marcy

Joe Marcy

  • 1 Post
  • 0 Reply Likes
But it's NOT fixed as of 14.2.1.

Running PS CC on a 27" iMac, 2.9ghz Intel Core iS, 16gb, 1600 Mhz, DDR3.
PS CC Version 14.2.1 64bit.

Every time I hit 'X' to switch colors, and SO many other functions, I get the error popup. Check the log, and:

2014:05:23 09:25:28 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20140207.r.570/photoshop/main/photoshop/xcode/../sources/USheet.cpp : 459 : REQUIRE failed

What DID fix it was resetting Settings within Photoshop.

Shift+Cmd+Opt, Open Photoshop, hit "Yes".
Photo of Maiken Petersen

Maiken Petersen

  • 1 Post
  • 0 Reply Likes
I have the same problem
Photo of Damon Langlois

Damon Langlois

  • 1 Post
  • 0 Reply Likes
I have the same problem! The above fixed it! Thanks!!!!
"What DID fix it was resetting Settings within Photoshop.

Shift+Cmd+Opt, Open Photoshop, hit "Yes".
Photo of Caitlin Bauer

Caitlin Bauer

  • 2 Posts
  • 0 Reply Likes
I reset my preferences, still having the issue.
Photo of Sessionista Ng Joa

Sessionista Ng Joa

  • 1 Post
  • 1 Reply Like
THIS IS WHAT HAPPEN WHEN I USE SHAPE TOOL.