Edit in Photoshop issues after 7.5 update

  • 1
  • Problem
  • Updated 10 months ago
  • Solved
I recently updated to Lightroom Classic CC 7.5 and since then whenever I right click a photo that was previously edited in Photoshop and choose "Edit in Photoshop" again to make changes, Lightroom becomes unresponsive, Photoshop does not open with the photo to edit.
I have to use Task Manager and completely End Task Lightroom.
A completely unedited photo (RAW) opens in Photoshop just fine.
It significantly impacts my edit time dealing with this issue.
This all worked fine before the update.
Photo of Enzo Gianni

Enzo Gianni

  • 4 Posts
  • 3 Reply Likes

Posted 10 months ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 5544 Posts
  • 1166 Reply Likes
Resetting preferences will normally cure this type of behavior. 

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom. 
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?
Photo of Enzo Gianni

Enzo Gianni

  • 4 Posts
  • 3 Reply Likes
Wow people, all the complaints. That's all I see on social media, people complaining.
I was just happy that this resolved my issue as I was on a magazine deadline.
Reconfiguring my Preferences again took all but 5 minutes.
Not a big price to pay at all in comparison to the workaround I had to do when it wasn't working right.
Photo of Art M.

Art M.

  • 87 Posts
  • 18 Reply Likes
I'm assuming that Rikk reported the bug to people that can fix it, but perhaps Rikk would like to confirm.
Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes
Don't be fooled Enzo,

I don't care spending 5 minutes of my time once in order to definitively fix a problem. But a bug that is not fixed is a bug that will show up again. The problem was that your preference file was corrupted. resetting it of course fixed the issue. For a while... But the reason for which that file was corrupted is still unknown (by the way, this problem in LR is lasting since years). So be prepared to be bothered again.

I can list many LR issues that I can fix with a workaround. This doesn't take more than a few minutes each time. However, some of these problems are here since the beginning of LR.  So, minutes of wasted time are adding up since years. This probably makes many hours of wasted time that I could have used for more exciting tasks.
Photo of John Schwaller

John Schwaller

  • 8 Posts
  • 4 Reply Likes
It’s like rebooting a computer or iPhone when things are not working correctly. Sometimes these gadgets (hardware + software) lose their “brains” and need to be restarted. It just is!
Photo of Patrick Philippot

Patrick Philippot

  • 479 Posts
  • 134 Reply Likes

This is an anthropomorphic view of things. The only brain in question is the developer's one. When it doesn't function correctly this produces bugs which are the representation of a wrong reasoning. Rebooting, resetting and the like don't fix anything. This just puts the device or the program in another state called "waiting for the next operations that will allow the bug to show up again". It's just putting the head in the sand while the bug might quietly continue to corrupt things on your system.