Edit in...no longer connects from Lightroom CC to Photoshop CC

  • 1
  • Problem
  • Updated 2 years ago
Each time I download a Photoshop CC update the automatic LRCC link to “edit in photoshop cc 2015” no longer functions. I always have to reinstall PSCC.. Why?

I get error reports.

Then when I manually open PSCC the photo I want to edit from Lightroom opens...

Help.
Photo of Keri Frankenstein

Keri Frankenstein

  • 5 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3818 Posts
  • 1263 Reply Likes
What do the error reports say?
Photo of Keri Frankenstein

Keri Frankenstein

  • 5 Posts
  • 0 Reply Likes
First - If Photoshop is already open the photo will open via Edit in... Here are the two dialog boxes I get:



Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 765 Reply Likes
Your Photoshop installation is corrupt on disk and can't be loaded.
You need to uninstall Photoshop, check your disk for problems (and repair if possible), then reinstall Photoshop.

If SafetyNet is your backup disk, then you're trying to launch the wrong copy, and the copy on the backup disk is incomplete. Plus you need to complain to whomever wrote your backup software, because it's bad.
Photo of Keri Frankenstein

Keri Frankenstein

  • 5 Posts
  • 0 Reply Likes
Thanks for helping.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 3818 Posts
  • 1263 Reply Likes
I'd also suggest blocking it from the backup, as if you needed to restore from backups, you'd be better off installing software like PS from their installers anyway. And if PS isn't on the backup drive, LR won't try to open it, so you'll kill a few birds with one stone.
Photo of Keri Frankenstein

Keri Frankenstein

  • 5 Posts
  • 0 Reply Likes
Okay so you are saying - go into Carbon Copy Cloner (CCC) and uncheck the PSCC and LRCC applications from being backed up/copied. That is easy to do. I'll try that and reinstall PSCC. Not really sure CCC is bad as a back up I probably don't have it set up correctly. Obviously. Thanks for your help.