Lightroom Classic: Edit Capture Time - Failing to refresh Library Module right side display

  • 2
  • Problem
  • Updated 2 weeks ago
  • Solved
  • (Edited)
When I amend the capture date or time for a photo the right hand side metadata panel fails to show the updated date and time until I deselect that photo and reselect it. The update should occur as soon as I save the action to amend the file. This is an annoying bug.
Photo of Steve Swayne

Steve Swayne

  • 24 Posts
  • 3 Reply Likes

Posted 3 weeks ago

  • 2
Photo of Smit Keniya

Smit Keniya, Employee

  • 203 Posts
  • 92 Reply Likes
Hi Steve,

I tried with both macOS and Windows and I was not able to reproduce the issue with Lightroom Classic 8.0 (Oct 2018 release).

Could you confirm if you are using LrClassic 8.0? Could you also share System Info (Lightroom Classic > Help menu > System Info)?

Also, does it happen with all the images or just particular type of images?

Thanks,
Smit Keniya
Lightroom Classic CC Team
Photo of Steve Swayne

Steve Swayne

  • 24 Posts
  • 3 Reply Likes
Hi, I am using Lightroom Classic CC v8.0. Only with JPG images that I am working on.

Lightroom Classic version: 8.0 [ 1193777 ]License: Creative Cloud
Language setting: en-AU
Operating system: Mac OS 10
Version: 10.14.0 [18A391]
Application architecture: x64
Logical processor count: 8
Processor speed: 4.0 GHz
Built-in memory: 32,768.0 MB
Real memory available to Lightroom: 32,768.0 MB
Real memory used by Lightroom: 1,789.9 MB (5.4%)
Virtual memory used by Lightroom: 4,134.4 MB
Memory cache size: 22.4MB
Internal Camera Raw revision: 61
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 20MB / 16383MB (0%)
Camera Raw real memory: 21MB / 32768MB (0%)
Displays: 1) 5120x2880, 2) 3840x2160

Graphics Processor Info: 
Metal: AMD Radeon R9 M395X



Application folder: /Applications/Adobe Lightroom Classic CC
Library Path: /Users/Serendigity/Pictures/01 Steve's Pictures/01 Steve's Image Library/Steve's Lightroom Image Catalogue/Steve's Images.lrcat
Settings Folder: /Users/Serendigity/Library/Application Support/Adobe/Lightroom

Installed Plugins: 
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Canon Tether Plugin
4) DxO OpticsPro 10
5) DxO OpticsPro 10 Importer
6) Export to Autopano Giga
7) Export to Photomatix Pro
8) Facebook
9) Flickr
10) HDR Efex Pro 2
11) LRT Export 4
12) Nikon Tether Plugin

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Built-in Output
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: 12.1x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon R9 M395X OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-2.0.36
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 


Photo of Smit Keniya

Smit Keniya, Employee

  • 201 Posts
  • 91 Reply Likes
Hi Steve,

I tried the same on macOS Mojave with JPG images and I was not able to reproduce the issue.

It could be specific to the files or the catalog. Could you share some of your JPGs where you are facing this issue and also the catalog (.lrcat) file with us at keniya@adobe.com

Thanks,
Smit
Lightroom Classic CC Team
Photo of Steve Swayne

Steve Swayne

  • 24 Posts
  • 3 Reply Likes
Hi, I just had a look at the files again and the fault is related to a bunch of analog era slides photos that were scanned over 15 years ago and also to some early Kodak DC200 images from 1998.  I believe now that the problems are related to corrupted JPG exif info which Lightroom was struggling with, and not the actual software.  I cannot reproduce it with any files I have as they have all now had their metadata rewritten and corrected.  So I guess this issue can be closed off.  Perhaps a better way to edit metadata in the file such as the way GraphicConverter can edit metadata would be nice, could be an additional module?
Photo of Smit Keniya

Smit Keniya, Employee

  • 201 Posts
  • 91 Reply Likes
I have marked this thread as solved. Regarding enhancements for Edit Metadata, you could submit an idea (a new thread).