Edit -> autoblend layers not working as expected to blend faces

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
I am trying to replace a face using a technique that is new to me but apparently common. As explained in this youtube tutorial or this one
you can duplicate a face, create a selection around the new face,
contract the selection and erase the old face from a duplicate of the
background, select the two layers, Edit->Autoblend Layers and it
should be magic. I try and I get this
(including all three layers including original background, the
dialogue, and the result). I have tried selecting all three layers,
deleting the original background layer, and converting the image to 8
bit. Any ideas why this doesn't work for me?

EDIT: I had a two feather pixel and anti-aliasing on the lasso tool used to select the face. Changed
it to 0px and no anti-aliasing. Made it worse, not better. Also tried Stack instead of Panorama.
Photo of David Annis

David Annis

  • 3 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Cristen Gillespie

Cristen Gillespie

  • 86 Posts
  • 16 Reply Likes
I just tried it. I think the 2nd tutorial is the one to follow. The first isn't very well done and it might be easy to miss some steps. I believe the lasso is set to 0px and antialiasing on. Are you sure you didn't forget to contract the selection of the copied face by 5 or more pixels before targeting the duplicate layer of the face you want to replace and deleting the selection on that layer? When I forgot, I got ugly edges. When I contracted the selection by 5 pixels, I got a smooth transition using the settings he used in the video.