Photoshop 21.x: Duplicating layers just stopped working for me mid flow

  • 1
  • Problem
  • Updated 2 months ago
  • (Edited)
Ive been editing an image with a fair few layers in smart objects.  I've suddenly just not been able to duplicate anymore layers.  Why?  How can I fix this problem... I need to finish my edit...
Photo of Laura Abbott

Laura Abbott

  • 3 Posts
  • 1 Reply Like
  • frustrated as I don't know why it has stopped working for me.

Posted 2 months ago

  • 1
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1530 Posts
  • 307 Reply Likes
Please post more meaningful information – how do you duplicate exactly, can you post a screenshot including the pertinent Panels, ...? 

What have you done for trouble-shooting so far? 

Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point:

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html

Photo of Laura Abbott

Laura Abbott

  • 3 Posts
  • 1 Reply Like
I mean by going into the 'layer' menu and selecting 'duplicate layer' or 'duplicate group'.  It was working.  3 hours into editing it stopped.  I also now can not just drag and drop a layer from one document to another which previously worked.
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1530 Posts
  • 307 Reply Likes
Have you restored the Preferences yet? 
Photo of Laura Abbott

Laura Abbott

  • 3 Posts
  • 1 Reply Like
Thanks Christop for the help!  I worked out the issue.  It so happens you can't duplicate a group if you have a smart object within it.  I had converted so many group layers into smart objects without realising this is why suddenly I couldn't duplicate anymore.  I didn't know this would prevent duplicating groups. (too much screen time)
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1530 Posts
  • 307 Reply Likes
I seem to have no problem duplicating Groups containing Smart Objects (neither with Duplicate Group nor with Layer Via Copy). 


Can you still reproduce the issue? 
If so could you please post a screenshot with the pertinent Panels (Toolbar, Layers, Channels, Options Bar, ...) visible? 
(Edited)