Lightroom Classic: Duplicates detection is not working well for images with uppercase accent letters

  • 2
  • Problem
  • Updated 2 months ago
  • Acknowledged
  • (Edited)
Hi,



I've found a bug in Lightroom Classic, including the newest version. I'm using Windows 10.

Please don't tell me that accents are special characters and software can't handle them. We are in unicode world and any char is easy to handle.


 

So what's the problem?

Duplicates detection is not working well for images with uppercase accent letters in the filename and it will import the same images multiple times. Detection is working fine with lowercase accent letters in the filename.

I've tried "synchronize folder" and if there is any new image, it will import the image and than every image with uppercase accent letter... Usual import dialog has the same problem.

 

How to reproduce?

Let's have any image in LR catalog. Rename to Á.jpg. Click on Import. Choose directory which contains this image and check "don't import duplicates". This image with uppercase accent letter will be imported anyway.

 

Which characters?

I've tried "Á, Č, Ě", but there will be much more letters.Probably from other languages too... See https://en.wikipedia.org/wiki/Czech_orthography#Alphabet




Lightroom Classic version: 7.5 [ 1186149 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Business Edition
Version: 10.0.17134
Application architecture: x64
System architecture: x64
Logical processor count: 6
Processor speed: 3,6 GHz
Built-in memory: 7605,9 MB
Real memory available to Lightroom: 7605,9 MB
Real memory used by Lightroom: 954,6 MB (12,5%)
Virtual memory used by Lightroom: 974,6 MB
GDI objects count: 664
USER objects count: 2297
Process handles count: 1648
Memory cache size: 180,3MB
Internal Camera Raw revision: 1001
Maximum thread count used by Camera Raw: 4
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 326MB / 3802MB (8%)
Camera Raw real memory: 327MB / 7605MB (4%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 2560x1440
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No
Photo of Josef Rypáček

Josef Rypáček

  • 6 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 2
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 4247 Posts
  • 808 Reply Likes
Official Response
Ok, I was finally able to get it to reproduce. I've logged it for the Lightroom Classic team to fix.