Photoshop: Dragging layer no longer works (jumps back to original location)

  • 1
  • Problem
  • Updated 8 years ago
  • Solved
  • (Edited)
When I try to drag a layer in Photoshop it moves for a brief second and then jumps back to the original position no matter where I let go of it.

It almost looks like it's snapping to it's original position. (Verified all snap settings are off)

Here is a video of the problem:

I have tried, to no avail:
- Resetting settings
- Updating to latest version: 12.0.4 x64
- Full reinstall
- Full reinstall and updating to latest version: 12.0.4 x64
- Using a different mouse

It doesn't appear to be related to the file either. It happens in all files and does not happen on a different computer in the office.

I found a forum where someone reported the same issue earlier this month but it was a result of using a tablet. I do not have any other device attached aside from a keyboard and a mouse.

Forum post:
Photo of Nate


  • 2 Posts
  • 0 Reply Likes

Posted 8 years ago

  • 1
Photo of Charles Badland

Charles Badland

  • 60 Posts
  • 4 Reply Likes
There is a pretty long thread over at of this same problem. Looks like may be multiple issues. If you don't have a tablet, could be another app is causing a conflict. Do you have iCopy installed? If so try quitting and see if you still have the problem.
Anyway, look here to see if any other suggestions help:
Photo of Nate


  • 2 Posts
  • 0 Reply Likes
Nice, I didn't find that thread when I was searching.

I did have iCopy and after disabling 'copy mouse drags' from the iCopy settings it worked!

Appreciate the help.

This conversation is no longer open for comments or replies.