Drag & drop type import does not work in LR 5.0

  • 1
  • Problem
  • Updated 5 years ago
Drag & drop type import from Windows explorer or from Canon Digital Photo Professional does not work. Some LR4 version had the same problem but that worked fine in LR 4.4.
Photo of markkanen.teemu

markkanen.teemu

  • 5 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3697 Posts
  • 968 Reply Likes
Hmm, drag-and-drop of folders from Windows Explorer to LR 5 import is working in my configuration (Windows 7 64-bit):



I wonder what's different in your situation?
Photo of markkanen.teemu

markkanen.teemu

  • 5 Posts
  • 0 Reply Likes
Thank you for the response.

I have also 64 bit Windows 7 platform. I made some testing by using different "Privilege level" settings on Lightroom shortcut. Drag & drop type import did not work when LR was started up in "Run as Administrator" mode. If LR was started in non-administrator mode then drag & drop import worked. I am using admin mode because I have faced some problems related to LR plugin installation / usage if that mode is not used. I use Photomatix plugin a lot. I need to make some tests whether or not LR startup mode has any effect on Photomatix plugin behaviour.
Photo of John R. Ellis

John R. Ellis, Champion

  • 3697 Posts
  • 968 Reply Likes
I'm not an expert in Windows architecture, but I've also run into issues with programs running as administrator not interacting well with non-administrator programs. Perhaps the problem with Photomatix is a file-permissions issue and addressing that would let you run LR as non-administrator?
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2647 Posts
  • 337 Reply Likes
How are you doing a drag-and-drop import, what are you dropping onto?

When I do it, I drag-and-drop an image or set of images or folder or set of folders from Explorer to the central area in Library. You cannot DnD when Develop or another module besides Library is current, only Library.

What I see in your screenshot is the Import window already open but no thumbnails of import candidate pictures. Does that mean that you are trying to drag-and-drop onto the Import window or that your drag-and-drop to the central library area started up the Import panel but then no pictures showed?
Photo of markkanen.teemu

markkanen.teemu

  • 5 Posts
  • 0 Reply Likes
There are no thumbnails visible simply because import is rejected by LR. When I try to drag & drop then mouse pointer transforms as red ban sign. This type import works perfectly when LR is started up in non-administrator level mode.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2647 Posts
  • 337 Reply Likes
What are you dropping onto, the Library panel or the Import panel that you've already opened?
Photo of John R. Ellis

John R. Ellis, Champion

  • 3697 Posts
  • 968 Reply Likes
I'm pretty sure now that this is a Windows architectural issue, out of the control of Lightroom. Normally, I can drag-and-drop a file from Windows Explorer into Irfanview (a widely used picture viewer). But if I run Ifranview as administrator, the drag-and-drop silently fails.
Photo of markkanen.teemu

markkanen.teemu

  • 5 Posts
  • 0 Reply Likes
I tend to agree. It looks like there is no LR specific issue here.