Lightroom: Drag and Drop fails to move all files

  • 2
  • Problem
  • Updated 7 years ago
  • (Edited)
LR 3.5 Win 7 64 bit. Select a group of files in one folder, drag and drop to another folder. Almost always, but not 100% of the time, all the files except one get moved. One remains and generates a message saying file cannot be moved. You can then select that one file and move it successfully. This bug has been present for quite some time and over several versions, I have reported it before.
Photo of Matulaitis

Matulaitis

  • 6 Posts
  • 3 Reply Likes

Posted 7 years ago

  • 2
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
Are these folders and images on a local file system, or a remote/networked file system? If they are on a NAS or file server of any type, they fall into the second category.
Photo of Steve Sprengel

Steve Sprengel, Champion

  • 2586 Posts
  • 323 Reply Likes
If you've reported this, before, I've probably replied, before...

I think this happens because a background thread has the file open to compute a preview or check the metadata status or something else.

I don't think it is easy to change this behavior without rearchitecting LR to communicate file-busy status for every file operation in some central location so the drag-and-drop handler can wait until all files are unbusy. I would guess rearchitecting LR wouldn't be done for just this small annoyance, but who knows what might happen in LR 4 or LR 5.

You can minimize this issue by waiting until all background threads have finished doing things with the visible thumbnails which is sped up by minimizing the number of thumbnails on screen that need preview status checked or previews rendered.
Photo of Matulaitis

Matulaitis

  • 6 Posts
  • 3 Reply Likes
John, these files are on a NAS.

Steve, is there a visible way to detect when all background threads have finished?