Ditto on LR4 being slow

  • 1
  • Problem
  • Updated 6 years ago
Ditto on LR4 being slow. I know the good folks at Adobe will fix this soon. I am editing large RAW files (Nikon 14bit Lossless compression). My system is built for this type of work. I never complained before, but maybe it is time to allow for some optimizing, like in PS. My GPU is sitting idle (maybe 2% here and there) when in LR4, while my CPU is doing all of the work. My RAM has 60% free with LR4 open, PS on standby, and listening to music, surfing the web, etc. After a few minutes of opening a catalog, the develop tool sliders start having delays. It is nowhere near real-time. Just switching to a retouch brush takes 2 seconds. All of those seconds of waiting add up to hours in a day. I should mention I am using a WACOM, and that initially caused some issues in LR2 and 3. PLEASE, I BEG YOU, SPEED IT UP SOME. I would not complain if my system was being tapped-out, but when my processor is showing 40% use, I have loads of free RAM, etc... I am just left wondering why it is not leveraging my system more. Specs: AMD 1100T 6 core, Asus M5A99X EVO MB, 16 giggs of high-performance DDR3 RAM, Several WD Caviar Black Drives (64 bit versions), SSD for a scratch drive, and a Nvidia GTX 260 card (only thing other than a few HHDs carried over from old system). Well maintained, updates, antivirus, temp files, etc.
Photo of Matthew Kieffer

Matthew Kieffer

  • 5 Posts
  • 0 Reply Likes
  • undecided

Posted 6 years ago

  • 1
Photo of Becky Sowada

Becky Sowada, Adobe Employee

  • 508 Posts
  • 104 Reply Likes
Try the Lightroom 4.1 RC build, available at http://labs.adobe.com/technologies/li... and see if that resolves the performance problems for you.

Thanks,
Becky