Elements 10: can't update ACR past version 6.7

  • 1
  • Question
  • Updated 6 years ago
  • (Edited)
I purchased PSE10 on July 7, 2012 as a download. I have now discovered that the program will update ACR only as far as version 6.7. I have owned this software for less than 2 months and it would appear that I can not update ACR any higher than the 6.7 version. Is Photoshop going to allow any further ACR updates for my version of PSE 10 given how little time I have owned it?
Photo of Kevin McCartney

Kevin McCartney

  • 3 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of Dan Smith

Dan Smith

  • 225 Posts
  • 19 Reply Likes
I asked that same question shortly after camera raw 7.1 came out and never received a response, so my best guess is not till photoshop elements 11.

If you have a camera that isn't supported by 6.7 you could use the 7.1 DNG
Converter to convert your camera raw files to dng copies which should then open in pse 10.
Photo of Kevin McCartney

Kevin McCartney

  • 3 Posts
  • 0 Reply Likes
Thank you Dan for your thoughts. My issue is that this software is less than 2 months old and it appears that Adobe is going to force users to upgrade to PSE11 when it comes out if they want new camera raw availability. I was happry with PSE8 and only bought PSE10 because the 8 version would not update ACR to cover the cameras that I had. I am very unhappy that Adobe is not supporting folks who buy their products. I should not have to spend the time converting to DNG files on software only 2 months old. Adobe your product support does not impress me at all.
Photo of Dan Smith

Dan Smith

  • 225 Posts
  • 19 Reply Likes
i agree with everything your saying and i wish adobe would have given a public explanation as to why pse 10 is not being supported in the camera raw department without having to resort to the dng converter, being that the current production versions of elements should be supported imho.
Photo of Kevin McCartney

Kevin McCartney

  • 3 Posts
  • 0 Reply Likes
Dan the standard answer that I see on the Adobe site is we are not supporting the product and if that bothers you use DNG. I just found a page that says Camera Raw-Compatible Adobe Applications which lists PSE10 as compatible with camera raw plug in through version 6.7. I can understand having to upgrade from PSE8 to 10 because 2 generations is indeed a lifetime in the software world. Where I am amazed is that not only will they not support their current products but they can not even try to flog PSE11 because it does not exist. I can not understand why they have ACR 7.1 available but apparently are claiming the PSE10 is too old a version for update purposes. I tried 3 times last night to get on the supposed live chat to ask a company rep why they are acting this way to their customers but was unable to get in touch with the so called rep. I guess the answer to that question is because they can.