Lightroom: Directly opening .LRCAT files tries to reinstall lightroom 4

  • 4
  • Problem
  • Updated 3 years ago
  • (Edited)
whenever I click on an .lrcat file to launch a specific catalog it tries to install from the lightroom 4 temporary download location. This is on win 7 64, using the latest LR4 release.
Photo of M Eltsley

M Eltsley

  • 3 Posts
  • 1 Reply Like
  • frustrated

Posted 6 years ago

  • 4
Photo of cfransw

cfransw

  • 43 Posts
  • 4 Reply Likes
Yes, same over here.

Frans
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
Sounds like .lrcat files are associated with the wrong thing in the registry. Try resetting this to have them open with the Lr4 app.
Photo of cfransw

cfransw

  • 43 Posts
  • 4 Reply Likes
Yes , I've tried that. But it is already associated to LR4. Can make a change to open it with Photoshop 5(which opens Photoshop with error of course) but when I change it back to LR 4, it's still the same.

I looked in the Registry and changed the command key to old , now it works.
(replaced command by old see picture) I probably can delete this subkey.

Photo of M Eltsley

M Eltsley

  • 3 Posts
  • 1 Reply Like
I'll be damned. I did the same thing and it worked. I had reset the default "open with" action a few times already so I knew that did not fix it. But cfransw's solution to change the "command" action in the registry, or delete it, worked. Now it opens with lightroom as it is meant to. Interesting. Even more interesting that changing this away from lightroom and then back does not fix it. I believe this to be a bug in LR4, that it creates this messed up registry entry.

If I knew how I would create a quick .reg file that would delete this "command" entry and share it with everyone, but I am pretty sure just following these steps you can do it yourself.

Open regedit
find (search) for AdobeLightroom.lrcat
here is the full path HKEY_CLASSES_ROOT\AdobeLightroom.lrcat\shell\Open\command
expand shell
expand Open
expand command
delete the second entry (titled "command')
exit regedit
Photo of jdv

jdv, Champion

  • 728 Posts
  • 55 Reply Likes
The registry is actually cached, so how changes are picked up across the system is non-deterministic. So, sometimes you see weird behaviour like this.

It very well may be a defect in how the installer registers all the stuff that Windows needs registered, but remember that not everyone is seeing this. For example, I do not see this on Windows 7 64-bit or the Windows 8 beta.
Photo of M Eltsley

M Eltsley

  • 3 Posts
  • 1 Reply Like
Yes thanks, that is true, but I also need to keep in mind that while not everyone is seeing this, we did. In fact it didn't happen on another win7 64bit system of mine also with LR3 previously installed, but on this win 7 64bit machine it did. Thanks again for your suggestion earlier, even if it did not prove to be the fix.
Photo of cfransw

cfransw

  • 43 Posts
  • 4 Reply Likes
Same here, my laptop and desktop. and if someone is interested what's in the command subkey :
3E$}H*eeY=4z8_71?ky(LightroomBase>lnc8CN~E4@2*iy!V2.*4 "%1"
pcuMmT6+KASo.ng,NPDDLightroomBase>q0BD[WIOY=]t4pK{Hn1^ "%1"
Photo of Reynold Jaquet

Reynold Jaquet

  • 11 Posts
  • 1 Reply Like
In LR3 you could double-click on the lrcat file in the Windows explorer and LR3 would open with that catalog.

In LR4, this does not work anymore.
When you double-click comes a message telling you that LR4 is configuring, which does not make any sense at all.
LR does not open.

This reply was created from a merged topic originally titled
Cannot open LR4 from the Windows explorer.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 372 Reply Likes
Thank you for providing the temporary solution.

Adobe: Please fix this in next rev - some startup scripts are depending on ability to open catalog directly.
Photo of georg m

georg m

  • 18 Posts
  • 0 Reply Likes
still the same problem with LR 5 on my win7 32 laptop and win7 64 office-machine.

the above solution worked though.

that's in my command subkey, if adobe is reading:
DTHo+-SW8@Tm5FbnD^ApLightroomBase>p1*L'}{WX8[+3vKW,.(5 "%1"